Missing all new apps

So Umbrel seems to be working fine other than I’m missing new apps that were announced on Twitter. The last app I have available is the Nostr Relay.

Is there some way to force the update of new apps to show in the Umbrel app store on the node?

I had this same issue. Installing a fresh copy of the OS onto a new SD card fixed it for me.

If a restart doesn’t help you can SSH and run this command:

cd ~umbrel
sudo scripts/repo update

If successful your app store should now be up-to-date, if not please share any errors it outputs and happy to further assist

Hmm here is what im getting now:

umbrel@umbrel:~/umbrel $ sudo scripts/repo update
Processing: https://github.com/getumbrel/umbrel-apps.git
Updating repo: https://github.com/getumbrel/umbrel-apps.git (master)
Updating f6b0591..6babf8e
error: Unable to create '/home/umbrel/umbrel/repos/https---github-com-getumbrel-umbrel-apps-git/.git/index.lock': File exists.

Another git process seems to be running in this repository, e.g.
an editor opened by 'git commit'. Please make sure all processes
are terminated then try again. If it still fails, a git process
may have crashed in this repository earlier:
remove the file manually to continue.

Processing: https://github.com/muthudotbtc/umbrel-openordex-app-store
Updating repo: https://github.com/muthudotbtc/umbrel-openordex-app-store (master)
Already up to date.

umbrel@umbrel:~/umbrel $

Any ideas? I have tried reinstalling Umbrel OS on the SD card and still have this issue.

maybe this community app store is causing the issue?

I was able to fix this issue by removing the index.lock file with

sudo rm -f /home/umbrel/umbrel/repos/https---github-com-getumbrel-umbrel-apps-git/.git/index.lock

Then i ran

cd ~umbrel
sudo scripts/repo update

So im good now. =)