App Store not updating for me

I see on the social media that there are several new Umbrel apps and app updates, but they’re not showing up for me in my app store. I think my OS is current - 0.5.3 on RPi4. I’ve tried restarting. That didn’t change anything. What else can I try?

1 Like

Let’s try to manually update an app…

After you login via SSH (you can see steps here Official Umbrel Troubleshooting Guide and FAQ under How to SSH into Umbrel on Rasperry Pi), then let’s try to manually update an app, we can troubleshoot by first attempting the Tailscale app, or replace its name with another applicable one if you’d like if you don’t have Tailscale… using this command:

sudo ~/umbrel/scripts/app update tailscale

Alternatively, you can also install an app as well with this command:

sudo ~/umbrel/scripts/app install tailscale

You can see the correct names of the apps to use in this command where they are listed here:

After attempting the manual update or install please let me know if it hangs on any errors or if you experience any issues here. If it gets stuck on a downloading line here it will show you a percentage if it is indeed progressing. If it is slow can I confirm if you are connected via Wi-Fi or ethernet, and what is the results of an internet speedtest? ( Also, out of curiosity can you share RAM and Storage Usage from settings?

Also, I’m happy to review your debug log- please share this via going to System > Troubleshoot > Start

Usually, restarting via System > Restart again and then just waiting a few extra minutes resolves this issue and the updates should become available- otherwise, happy to further troubleshoot!

1 Like

Installing fresh OS onto new SD card fixed this issue for me. All my apps are now up to date and Umbrel is humming along happily.

1 Like

The update command solution also solved an issue I had where an app update triggered from the GUI never completed for a couple days and the front end update button was still pulsating in “Updating” state across machine reboots.