Mempool "Error loading address data" still happening

I am able to use mempool fine with txid and most addresses, but it throws the “Error loading address data.” when I attempt to lookup an address that starts with 3 (segwit)?

Those same addresses work fine in but will not load in my umbrel mempool app?

Is this a known issue?

I am running v0.4.16 and have already tried uninstalling mempool, rebooting my node and then installing mempool app again. My node is fully synced and until my reboot today was up for 8 months.

That means your electrs is still indexing.
Patience an next time reboot your node more often.

I am pretty sure my indexing is fine, I am not waiting on anything, see my logs below.

sudo docker-compose logs -f electrs
I see tons of (I assume this is normal?)
“electrs::electrum] your wallet uses less efficient method of querying electrs, consider contacting the developer of your wallet. Reason: blockchain.scripthash.get_history called for unsubscribed scripthash:”

Then I see “electrs::index] indexing 1 blocks: [727954…727954]”
“electrs::chain] chain updated: tip…”

It just did 727955, so I believe that means I am current, but I still get the same error looking up a bitcoin address that starts with 3. Same address displays fine in just not in my umbrel. What else can I check? Can you try looking up a bitcoin address that starts with a 3?

try with the txid of that address

I can’t it is a deposit address at an exchange

Please show your bitcoin.conf file.
No problem with mempool addresses here.