Ls: reading directory '.': Input/output error

Hi all - my umbrel has been stuck synchronizing at block 22,538 for a while now. I tried to read the logs, but get the error: “Error: Failed to fetch debug data.” So then I tried to ssh into the umbrel, but whenever I tried to access the umbrel folder I get this error: “ls: reading directory ‘.’: Input/output error”. I also cannot access subfolders.

I thought maybe something was wrong with the power, so I used “vcgencmd get_throttled” but it returns “throttled=0x0”, so everything should be ok on the power front. I also checked to make sure the SSD was mounted correctly using “df -h” and it looks like the SSD is being used.

I’m kinda at a loss about this problem and haven’t been able to find any resolutions online. I already reformatted the SSD and reflashed umbrel, but the problem persists. Should I just buy a new rpi?

Thanks for any help!

Maybe just a new power adapter. That little fucker is the source of all evil that can happen.

Thanks! I’ll try that. I thought I had the official one, but maybe I got hoodwinked. I’m just hoping I don’t need a new pi because those little fuckers are impossible to find now.

Get an official RaspPi power adapter. Also have a second USB cable, it is often a problematic part.