Low Ram Error Message

Getting this low ram message on Umbrel. I’m uninstalling some apps but am wondering how to upgrade a pi without killing my node? Is this possible? @DarthCoin


I’ve also started getting this error after the most recent update.

I am also getting this error. I think I should have gotten the 8GB version. What else can we do besides deleting apps?

I recently started getting this message. When I look at the logs mempool space is taking up a lot of ram, more than it had previously. I only have 3 apps running and didn’t get this message before the recent update.

Hey guys! Could you share the RAM usage (in percent) of each app (you can get that in the logs: Settings > Troubleshoot) and your Pi version?

I updated Umbrel yesterday and that seemed to bring ram usage down a little bit. It’s still in the 2.8G range with only 3 apps installed.

And I have the Raspberry Pi 4 Model B 2019 Quad Core 64 Bit WiFi Bluetooth (4GB)

Brel log

I reinstalled mempool space and did not have the ram warning when logging off/on. It is using less memory then before I uninstalled.

@erinemalone @WalletInspector Thanks for the details. It seems that the Mempool app is using a lot memory. There is a discussion ongoing with Mempool devs to solve this: https://github.com/mempool/mempool/issues/486.

1 Like

is there a command to stop the mempool app? Is it critical for operations?

I have same memory problem. I bought the recommended 4 GB pi and don’t run any applications. It worked great for a few months and then this started happening.

I am debating upgrading to 3.14, but I am remote from my node, so it is risky that i run into problems and need to physically be at my device.

It has also crashed one i think due to this problem. Is there any way to see past logs (the log download is only the most recent one).

Thanks all for any help!

Unfortunately, there is no way to stop an app without installing it.

Can you also check the memory usage in the logs?

Hi, just curious, seeing other 4GB Pi users having the same issue, did you find a fix it in the end? Or just upgrade to 8Gb and forget it?
It’s an interesting issue this, why is affecting only 4GB version users.

Started seeing this issue today on Raspberry Pi 4 4GB:



Memory usage
              total        used        free      shared  buff/cache   available
Mem:           3.8G        3.1G        154M         18M        563M        648M
Swap:          4.1G        176M        3.9G

total: 81.1%
samourai-server: 15.8%
btcpay-server: 12.7%
bluewallet: 9.3%
bitcoin: 8.9%
system: 8.5%
lnd: 6.8%
electrs: 6.5%
mempool: 5.5%
sphinx-relay: 2.2%
specter-desktop: 1.3%
btc-rpc-explorer: 1.3%
tor: 0.8%
lightning-terminal: 0.8%
ride-the-lightning: 0.7%

Memory monitor logs
2021-06-29 09:17:14 Memory monitor running!
 5118 ?        S      0:00 bash ./scripts/memory-monitor
Memory monitor is already running
2021-07-15 10:30:49 Memory monitor running!
2021-07-27 12:25:54 Warning memory usage at 91%
2021-07-27 21:12:01 Warning memory usage at 91%
2021-07-28 04:18:06 Warning memory usage at 91%
2021-07-28 08:12:27 Memory monitor running!
2021-07-28 08:30:07 Memory monitor running!
2021-07-28 08:41:54 Memory monitor running!

Filesystem information
Filesystem      Size  Used Avail Use% Mounted on
/dev/root        15G  9.4G  4.4G  69% /
/dev/sda1       880G  507G  328G  61% /home/umbrel/umbrel

The latest upgrade in combination with deleting most of the apps brought my memory back down. I did just buy an 8gb and plan on upgrading this weekend.

Hi OP. About your original question. I also had the same message and so upgraded to the 8GB Rasp Pi. Easy to do. The blockchain stays and all you do is flash the OS to the SD and start it up again. Very quick and smooth transition. No RAM messages since then and can run as many apps as I like.

Yeah I did this yesterday and it worked great.

i was going to ask @PeterBTC and @erinemalone how to transition to new one without syncing up the whole blockchain…which you partially answered but i was hoping for one small clarification from OGs

why do you need to flash another microSD card? you can’t just pop the microSD card into new 8GB pi (meaning it has some data persisted on microSD? for OS purposes?)

does Umbrel OS write any of its own data to microSD… or does umbrel-os write to the SSD post boot its own OS data ? (i haven’t thought about it/explored all the dirs yet, just got mine running 1.5 days ago and synced at 92% so just preemptively asking before that day even comes)

also, do you personally use any any SSD/HDD docks to clone your SSDs for massive 400GB backups to avoid downtime in case of technical issues ?

thanks in advance

Hi. I’m not sure I’m qualified to answer. I believe every restart of the node requires a re-flash of the OS. It does with mine. It’s a drag, but seems to be the only way to restart it after stopping it. Anyway, you could try just sticking the old Micro SD into the new Pi. As for backup of the blockchain, no I don’t do that. SSDs are too expensive. I just trust that mine will last a few years.

1 Like

i hear you (could go cheaper and use HDD instead of SSD, and only throw on SSD if it ever broke… just thinking out loud). i saw someone in Plebnet suggest the docking/cloning ability and just scoping out the scene, see what rest of yall think. thanks for your opinion

I didn’t flash my sd card, I just popped it in the new pi. The only thing that changes with the migration is your IP address.
I need to figure out a cloning option for my ssd.


i see. makes perfect sense. thanks for sharing