Swap File for more RAM - Help

Hello dear Umbrel community,

My node hardware is:
-RB pi 4 (4GB)

I’ve noticed that ~2-3 days after installing several apps in my Umbrel node (BTC explorer, Mempool, Blue Wallet or more) I can’t access my Umbrel Dashboard (please see image below in which the loading bar is frozen)

If I use the command: sudo reboot, it will temporarily solve the problem for ~2-3 days, but after that period of time the same problem comes back.

I tried using the following command to solve this issue:

cd umbrel
sudo systemctl stop umbrel-startup && sudo rm -rf ~/umbrel/lnd/!(lnd.conf) && sudo rm -f ~/umbrel/db/user.json && sudo rm -f ~/umbrel/db/umbrel-seed/seed && sudo systemctl start umbrel-startup

However, this command, as you know, deletes all apps and restricts me to have LN channels up all the time. And even doing this, installing the apps again will result in the same problem.

Here are the Umbrel Logs I got just when my node crashes, which occurs ~1-2 days after installing the apps.

-Umbrel logs: https://pastebin.com/VVhqv2Ma

I believe this issue might be related to RAM limitations of my RB pi 4 (only 4 GB), as it’s been very difficult to find 8GB ones these days.

Dear developers @DarthCoin & @louneskmt, is it possible to use a Swap File on the SSD to have more RAM available? Do you think this might help to solve this issue for those Users that do not count with more RAM? If so, could you please kindly indicate how we can do so?

I’d greatly appreciate your help on this.

No. Will not solve it.
Just keep your node only with BTC/LN node + RTL/TH. mempool is not really necessary and that one is eating your resources.

Prepare to an upgrade is the only solution.
No RPi with 8GB available? Simple: buy a damn normal PC/barebone with 8GB and move all data to it.

1 Like

This issue looks very interesting for me, for I have same apps, but I don´t have those crashes.
One thing, I only installed any apps after full IBD and 100 sync.
Well, suspect you may have a hardware issue behind this.
I like to keep the ‘top’ linux app running, it shows memory use and command eating cpu

1 Like

@LoboGuara do you also have a 4GB RB pi?

No, i have a 8GB that i set total_mem=4096 to limit memory to 4GB for experiment. I got no memory problems yet.

Use wire connection with fixed IP, helps with those web crashs. Set eth0 IP in /etc/dhcpcd.conf with an IP off of dhcp router range.

1 Like

There was a user here, posting how he did it with a VM with 512 GB RAM running Umbrel. I can’t find it right now, I know I saved the screenshot somewhere.

With 512GB life is easy… :smiley: With 2GB life still runs, but not so fast…

1 Like

I did some observations of cpu load with basic apps, and find that Mempool is by far a cpu eater champion. It loads a RasPi cpu core to 60% or more most of time.
So, I know it can give some privacy increase, but better not install it in a heavy loaded machine.

And it did not work even though he used VM of 512 GB RAM, right?

Oh no, it worked super nice…