Locks after startup, won't update, now won't boot w/new SD and image

Umbrel 0.5.1 on PI 4 (formerly a Casa 2 node).

Had been running happily for months, but recently went offline, although the Pi itself seemed to be running. Tried to connect through browser, then ssh, no joy.

Reluctantly, did an unplug/replug. No joy. Was busy, so let it sit for a week or two. Unplugged and moved to office desk, thinking I’d check the SD card. It started up, red steady and green blinky light, blue light on SSD - seemed okay. Huh. Joy?

Node claimed it was ~97% synced, which seemed odd, given that it’d been offline for weeks. Attempted to update from 0.5.1 to 0.5.3 from Settings; downloaded fine so then ran install from the settings page. Didn’t take. Sh*t.

Did a second try, because I was interrupted during the first update and didn’t see what was transpiring in real time. Update failed a second time, system remained at 0.5.1. After 12 minutes, system locked up, and I could not get access through either SSH or browser. Rebooted, lasted about the same amount of time again, then went unresponsive.

Ran Debug (see below).

Next, attempted command line update (see below). Also unsuccessful, but am Pi noob, so perhaps issue is between screen and seat?

Dug out Balena Etcher, downloaded/unziped 0.5.3 image, and reflashed SD. Flash failed to confirm.

Ordered new SD (Sandisk Ultra 32 GB). Flashed and confirmed. Progress?

Inserted new/flashed SSD in Pi. Pi fails to boot. Steady red light (no power problem); but no green lights. This is definitely not progress, actually even more failed than when began troubleshooting.

Reflashed both the new SD (again, successful) and the original (again, failed). New/reflashed SD reinserted (yes, the new 32GB, not old 16GB - double-checked). Red light, no green lights, no joy.

Transparency: While working on this, had also removed a dead/POS Fan Shim fan and replaced with the third Fan Shim I’ve had on this device. Have been running the Pi topless in a closet with one of the mesh devices and it had been steady cool, ever since the Fan Shim #2 went noisy and erratic about 6 months ago.

Have checked against pre-install photo, and 5V jumper is on Pin 2, which I believe is correct - or at least the same as before, when things were running smoothly. Removed the new fan, as that seems like a secondary problem, and wanted to eliminate that part as a source of concern.

At this point, I’m running out of ideas, open to other strategies.

– Debug and command line stuff below –

= Umbrel debug info =

Umbrel version


Flashed OS version


Raspberry Pi Model

Revision : c03111
Serial : 100000001d869b22
Model : Raspberry Pi 4 Model B Rev 1.1


Feb 25 2021 12:10:40
Copyright © 2012 Broadcom
version 564e5f9b852b23a330b1764bcf0b2d022a20afd0 (clean) (release) (start)





Memory usage

          total        used        free      shared  buff/cache   available

Mem: 3.8G 203M 3.0G 6.0M 627M 3.5G
Swap: 4.1G 73M 4.0G

[1]+ Stopped ~/umbrel/scripts/debug
umbrel@umbrel:~/umbrel $ cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.4.8cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.5.3
[sudo] password for umbrel:
Cloning into ‘/tmp/umbrel-update’…
warning: Could not find remote branch v0.4.8cd to clone.
fatal: Remote branch v0.4.8cd not found in upstream origin
fatal: not a git repository: ‘/tmp/umbrel-update//.git’
mv: cannot stat ‘/tmp/umbrel-update//info.json’: No such file or directory
jq: error: Could not open file /tmp/umbrel-update//info.json.orig: No such file or directory
Update path doesn’t seem to be an Umbrel install.
umbrel@umbrel:~/umbrel $ client_loop: send disconnect: Broken pipe

So where are you now?

Any chance its time to start over?

No case? Dont need a fan. A heatsync will be fine or nothing at all too.

Pi will throttle itself before it burns up.

So…where are you what can you do?

So, at the moment, dead in the water.

I have a second fresh SD card, but not sure it makes sense to flash a third.

Might be it’s time to buy a new Pi and start over - have my seed phrase, so that’s not an issue. But I also have an iMac that is on the fritz and only so much money available to randomly toss at hardware right now, so if it’s a software/system issue would prefer to get that sorted rather than just junk the current setup.

The chances it the pi is very very low.

Can you ssh in?

Can you get in the web interface?

Negative to both. No SSH; no http://umbrel.local.

Not even getting green lights, only a steady red power light.

Double checked to make sure the new and flashed SD card is inserted correctly - appears to be moron resistant, only goes in one way - contacts facing up, towards the bottom of the Pi board.

Confirmed that it is firmly and evenly seated.

unplug that fan.
unplug the ssd.
see what happens

Fan was already removed.

SSD has now also been removed, no difference. (SSD is a Sandisk 1TB 2.5" SDSSDA-1T00). No clue about how to connect it to one of the Macs to see if it’s working properly.

Also, purely out of curiosity, before removing SSD, tried a reflash of 0.5.1, since that version was known to have run. Nope.

Positive the sd card flashed properly and verified. …

Hmm, thst leaves the power supply.

Any chance you can plug thecpi into a tv so you can see if theres any boot text

Power supply is the original that came with the Casa Node 2, and I’m assuming the steady lit red light means that power is within spec.

Balena Etcher verified the flash (and didn’t verify the older card that’s been replaced). The new card has been reflashed/retried with 0.5.3 and 0.5.1 images, downloaded directly from:

Well I am running out of ideas.
Im starting to hope its under warranty still but I have a couple more ideas.

  1. plug it into a tv and boot it. See if there is any boot text.
  2. Very rare but the eeprom may have gotten corrupted.

First lets see if there is any boot text at all. Hook up your pi to the tv hdmi port.
And take a picture of any boot text.

if there is nothing there…


If your Raspberry Pi 4 will not boot, it is possible that the SPI EEPROM has become corrupted.

To check, remove the SD card, disconnect the device from power, then reconnect it. If the green LED does not flash, you will need to reprogram the EEPROM:

Download the bootloader
Extract it to an empty FAT-formatted SD card and insert it into your Raspberry Pi 4
Connect the power and wait for the green LED to flash quickly
use raspberry pi imager and download the bootloader to boot from the sd card

If those two options dont work I am out of ideas.

Same problem here. I thought the SD was dead (I received a warning to change it for a new one a couple of months ago), so I flashed a new one today using Rufus instead of Etcher, but I still can’t access the node.

Rapsberry’s red led is on and green blinking, Ethernet cable leds are both on and blinking, SSD’s blue led on. Umbrel versions 0.5.1 (previous) and 0.5.3 (actual).

Don’t know what to do.

check that your IP didnt change. Look in your router.