Lightning channel stuck in waiting close

After a power failure I had to restore my node.
All channels were closed except this one which is now stuck in waiting close for over a month.
Is there any way to recover these funds?
“total_limbo_balance”: “0”,
“pending_open_channels”: [
“pending_closing_channels”: [
“pending_force_closing_channels”: [
“waiting_close_channels”: [
“channel”: {
“remote_node_pub”: “02ab583d430015f3b6b41730434b5fac264901b50199f0b9becc0a98a365f581a9”,
“channel_point”: “24c53f91b0ce06b9135b6673a4aa9f8977d72070baf983d864283228303e3c5b:1”,
“capacity”: “3000000”,
“local_balance”: “0”,
“remote_balance”: “0”,
“local_chan_reserve_sat”: “0”,
“remote_chan_reserve_sat”: “0”,
“initiator”: “INITIATOR_LOCAL”,
“commitment_type”: “ANCHORS”,
“num_forwarding_packages”: “0”
“limbo_balance”: “0”,
“commitments”: {
“local_txid”: “”,
“remote_txid”: “”,
“remote_pending_txid”: “”,
“local_commit_fee_sat”: “0”,
“remote_commit_fee_sat”: “0”,
“remote_pending_commit_fee_sat”: “0”

Check in the Umbrel troubleshooting manual the section about how to check the pending close channels and if is necessary to force close.
But force closing is not really recommended, normally a closing channel takes time and you can see at what block height you will get the funds.

@DarthCoin I tried already to force close with
“~/umbrel/bin/lncli closechannel --force 24c53f91b0ce06b9135b6673a4aa9f8977d72070baf983d864283228303e3c5b 1”
it didn’t work
And it doesn’t show me any maturity_height either.

If you didn’t see any error in that process, just be patient, takes a while until is broadcasted

Just checked the logs
when i try to force close I receive the following error

lnd | 2022-02-02 21:46:04.005 [ERR] RPCS: [/lnrpc.Lightning/CloseChannel]: cannot close channel with state: ChanStatusRestored

makes no sense for me bc the channel is still stuck in waiting close

Hi, i have the same problem with my full note, did you have find a way to fix this problem?

Unfortunately not
I found a few similar cases online so this seems to happen regularly but no one has a solution
Looks like these funds are lost…

I have the same problem, nobody has a solution apparently. So funds are gone I guess?

I also facing the same problem. My Umbrel is on the latest version. And my 2 channels have been stuck for more than 2 months.

Still no fix, 7 days with a failed force close…!
I can see in the mempool and on that the channel is still open.

Same issue. I have 4 channels in this state. I had to do a node sweep after a recovery and 4 channels never closed. I have over 0.1 btc tied up too.

Any update? I have the same issue.

Hi. I’m having the exact same issue. channel status flags displays “ChanStatusLocalDataLoss|ChanStatusRestored”.

I had to start from scratch and currently have 4 channels in the “waiting_close_channels” list. all my other channels closed with no issue once I restored except those 4.

when i try to force close, I get the same error “cannot close channel with state: ChanStatusRestored”

have gone through the troubleshooting guide several times, as well as searched the forum, with no luck.

has no one found a solution to this?

Posted a possible solution here in case anyone is going through the same thing. There is currently an issue with CLN nodes when going through recovery. The linked solution appears to solve the problem.