[SOLVED] 2 Channels wont close after recovery

I recovered my node and have successfully settled the majority of my sats. However, I have two channels that wont close after a month. I have tried force closing via command:

umbrel/scripts/app compose lightning exec lnd lncli closechannel --force

But get the following error:

[lncli] rpc error: code = Unknown desc = cannot close channel with state: ChanStatusRestored

I’ve seen this on a couple other posts on here but it doesn’t look like there has ever been a solution posted to those pages. Any ideas?

looks like the channel is maybe not initialized correctly
try to recover it again with the backup
when you see the cannel with it’s full capacity try to close it again
you can also try using different app for this


I’ve tried restoring channel backups a few times, along with the command for scanning UTXOs. I’ve also had one of the peers restart their nodes to see if that would free anything up.

I’ll keep trying different channel recovery backups since I think that’s the only option I have left.

Not sure what apps to use, don’t see any options for me on RTL or Thunderhub

not so familiar with this but i think it ill take some time
otherwise you can force close these channels when the other person is not responding or something.
when you have the access you will get the funds back (i guess)
lightning is still somehow experimental but this should work.


Lots of steps took place so I’m not sure what exactly did it, but here is what happened for me:

After the initial channel recovery, I had two channels stuck closing. I performed reboots, asked the peers to reboot, scanned UTXOs, searched the forums, posted on here, and I couldn’t get anything to work. Then, I found an old sd card with umbrel on it from when I replaced it (due to that bug in the previous version). I booted up that old sd card and one channel immediately closed! But one was still stuck pending…so I deleted my lightning node app, recovered from the seed words, restored a channel backup, and there it was – the last of my sats recovered.

If anyone else is stuck, try recovering using seed words (again), and recover channels using backup (again). I used an older backup and that seemed to work for me…

looking for a solution too. for the same situation
any news?

I already posted above what worked for me.

  1. Delete and reinstall lightning node (again)
  2. Recover via seed phrase
  3. Select the channel backup recovery
  4. Let sync until channels close. If channel is stuck pending again, attempt with a different channel backup.

Here is a link to a more technical solution someone posted:

I have the same problem. Did you find a solution?