Issues starting with Umbrel

Hi and thanks in advance, yesterday I got my right installation and the SO worked perfectly. This morning I ytried to connect through Tor and I culdn´t, later I could connect through my laptop and I saw that I shuld started again, I put my number , the pass and when I arrived to the screen “Note down your secret words” and i clic Next the screen is hanging up all the time, if I click back the process stop and I can go back, but always start again and I come back to the same problem.

If I clic in the recover to put my 24 secret words it Happen the same, If I try to create a new user, the same.

I think the SO actuallized to 4.0 and I can´t acces now

Updated: now is worst I tried to refresh the adress http://umbrel.local and my computer can´t found umbrel I tried with Angry IP Scanner and my computer can´t found the raspberry connection it seems like disconnect . I am not at home until Monday, then I can see phisically te raspberry and my computer but if someone can have an idea about how solve this problem I´ll be grateful.

Thanks for your time