Installing with an SSD

Installing Umbrel on a Debian system should be the easiest thing in the world, and it is! Just

curl -L | bash

This works just fine, until Bitcoin runs out of space, because Umbrel installs the blockchain to the system drive! No option to choose the SSD, and no further installation instructions on the website.

curl -L | bash -$ --install-path /some/path

is suggested by bash, IF you’re quick enough to catch it. But

curl -L | bash -$ --install-path /media/mymachine/mySSD

returns a Docker error about AppArmor with MX Linux, and user permission errors under Debian. And I don’t see –install-path documented under curl or bash.

Installing Umbrel directly to the SSD brought up its own set of problems. Shouldn’t an attached 1-2 Tb SSD be the default installation, considering the size of the BTC blockchain? Where have I gone wrong?

I’d assume you could point ‘~/umbrel/data/storage/downloads’ to another directory that’s on your SSD, is this instance installed on a NUC/spare machine you have?

Just trying this out on my own machine and seeing if this works

Thanks. There is no ~/umbrel, which could be where I’m lost. Where is ~/umbrel/data/storage/downloads (or anything else) documented? Github just refers us back to the one-line curl -L | bash instruction on their homepage.

This must be something simple that I’m missing!

Interesting, what directories show up when you run ‘ls’ from root? Maybe you got unlucky with a bad install cause that’s weird

You’re right, it was weird! So I reinstalled, and there now is an ~/umbrel.

Running the Bitcoin Node installer, I see a link to this support forum, but nothing about disk configuration. The node installer directly starts blockchain sync to the system disk. How can thousands before me download to their SSDs without further instruction? Why isn’t this mentioned in this forum?

No, I don’t see an ~/umbrel/data/. There is an ~/umbrel/app-data/bitcoin/data/bitcoinblocks/ filling up system disk space, but my three questions still are: How do I direct this initial block download to my SSD?, where is the documentation?, how do I suspend downloading while figuring things out without killing processes or shutting the machine down?

I must have missed an instruction somewhere! Thanks for the help!

1 Like

Apologies, appears I mentioned the wrong path, but shifting app-data should be relatively easy. Here’s a great guide- the only change you will need to make is location of your drive instead of /mnt/hdd1tb/

Thanks for your efforts, but it didn’t work. I suspect it’s the mount points. My SSD is mounted automatically during bootup at /media/mySSD, and wouldn’t respond to your suggested command, to move data to sudo mv ~/umbrel/app-data /media/mymachine/mySSD/. I’m a Manjaro guy, and Debian just drives me nuts when I have to use it.

I’m going to try a reinstall, with EVERYTHING on the SSD. Maybe that’s how everyone does it? There’s no apparent documentation to show otherwise.

Nope! BIOS won’t let me install Debian to the SSD, and Umbrel installs to ~/umbrel, no matter what directory you install from.

End of the trail.

For the intention of installing in a different directory other than root, to install Umbrel on Linux via this method,

To specify path:

curl -L | bash -s -- --install-path path/to/external/drive

And replacing “path/to/external/drive” to the path of the different directory for the Umbrel to go in on the external drive

It looks like it just wants the extra hyphens there and -s etc.

Let me know if this works, and we can for sure just delete any other folders created of course

1 Like

Thanks @usernameisJim

Yes. I tried that instruction several times.

Debian assigns my SSD to /media/bee2/kea/, bee2 being my machine, and kea being the SSD.

Making my user a sudoer, and curl -L | bash -s – --install-path /media/bee2/kea returns

Error: Umbrel install path “/media/bee2/kea” already contains files
You can install Umbrel in a custom location with:

curl -L | bash -s – --install-path /some/path

I’ve reformatted the SSD with GParted, under the latest Debian and Xfce. Reformatted and renamed by the system and mounted on boot. Same error.

I’m convinced this is something about Debian that I am not aware of. It isn’t recognizing its own mounts, or I don’t have permission.

You will also want to check that the SSD is formatted appropriately for Umbrel. How to easily reformat an ext4 / Umbrel drive

Let me look a little further for you

Thanks! It was previously formatted on my Manjaro machine, but for this last post above, was formatted again on the Debian. Both ext4.

The SSD was previously used as a system disk, and permissioned root:root, preventing Umbrel from writing to the reformatted disk.

1 Like