Help setting up Ubuntu to run Umbrel

Does anyone have a step-by-step guide for a non-techie to setup Ubuntu to run Umbrel using an old PC, please?

I’m getting this error:

Hey @Bitmen! I’m sorry you’re having this problem,
You can install Umbrel using the install script :
curl -L https://umbrel.sh | bash
If you want to install Umbrel in a custom directory you can use :
curl -L https://umbrel.sh | bash -s -- --install-path /some/path
(replacing ‘/some/path’ with the path of your directory)

Let us know if it worked out for you! :v:

Thank you so much for helping out @Marcaday…but it seems there is another challenge. This is the error I’m getting:

It looks like you already created a directory called ‘Umbrel’ where you want to install Umbrel.
For the install script, you need to replace '/some/path' with the path of your Umbrel directory.
You can also add sudo to run the command as a root user.
So in your case, the command should look like
sudo curl -L https://umbrel.sh | bash -s -- --install-path ~/umbrel

@Marcaday thank you once again for your help. Sadly, I am really a complete non-techie, so what you are saying is above me. As a new user, I’m unable to add attachments or post more than one link :frowning: so, what I think is needed, please, is a step-by-step instruction of how to fix the problem. I’m eager to persevere with strengthening the Bitcoin network, but will need your help, please. Thanks for your patience :slightly_smiling_face:

I ran this sudo curl -L https://umbrel.sh | bash -s – --install-path ~/umbrel but the error is this:

mkdir: cannot create directory ‘/some’: Permission denied

Alright! No worries we’ll go through this together :smile:,
Before starting here are a few basic Unix commands that you want to know:

cd name_of_the_directory : change directory, you’ll move yourself to the desired directory (move backward: cd .. )
ls : list all files and folders in the current directory
pwd : gives you the absolute pathname of the current working directory
mkdir name : creates a directory called 'name’
sudo name_of_command : Will execute the command as a root user.

You can have more info for each of these commands by typing :
man name_of_command (e.g man ls)

Now that you know that, we can start our installation process.
If you want to install Umbrel at the root of your drive you can just use the installation script:

curl -L https://umbrel.sh | bash -s

If you want to install Umbrel on a custom location, you want to specify to the install script the path of the folder in which you wish to install Umbrel.

(you can move in & out from a directory using cd, and get the full path of this directory using pwd while you are in it)

In your Terminal, I can see that you have already created a directory called ‘umbrel’, in your main Drive (~/umbrel/)
So if you want to Install Umbrel specifically in this location you can use the install script & specify the Umbrel directory path.

curl -L https://umbrel.sh | bash -s – --install-path ~/umbrel

As it looks that the umbrel folder is already in your main drive you could just use the basic installation script:

curl -L https://umbrel.sh | bash -s

If you have any issues during the installation, please provide a picture or a trace of what you did and which error you got (You can share text using pastebin.com)

Keep us posted!

Thanks so much, but it isn’t working. This is just too difficult. Please can you send me another way to install Umbrel on an old PC. There must be an easier way and I want to help other people run Bitcoin nodes, but it shouldn’t be this difficult. Thanks again, I really appreciate your efforts.

Sorry to hear that it hasn’t worked :confused:
What isn’t working? Could you send an Image or paste what you’ve done on pastebin.com and share the link with us? So that we can see what error happened and try to fix it :v:

ok here it is:

It looks like there are already some files in your ~/umbrel directory
You should use an empty directory for the installation script to work, you can either remove the files in this directory or move them somewhere else.
you can list all the files in your directory using:
ls
and remove a file using:
rm name_of_file
If all the files in your ~/umbrel folder are unnecessary you can remove them all using
sudo rm -rf ~/umbrel/*
( :warning:Do not mess with this command if you are unsure of what you are doing)

Once your ~/umbrel directory is empty you should be able to install it correctly with the install script:
curl -L https://umbrel.sh | bash -s – --install-path ~/umbrel

This time will be the good one!

1 Like

Thanks again for all the help, it was looking promising, but then an error:

https://pastebin.com/mbL3AnMV

Morning, @Marcaday, hope you’re well. Was wondering whether you had managed to have a look at this recent error on Pastebin as I see the post has been ‘‘hidden by community flags’’.

Hey @Bitmen, I hope you’re doing well!
I’ve taken a look at the logs and from my perspective, it might be an issue with the gzip package.

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0/usr/bin/gzip: 1: ELF: not found
/usr/bin/gzip: 3: : not found

Could you try to install gzip before doing the installation?
sudo apt install gzip
then run the same command to install umbrel:
curl -L https://umbrel.sh | bash -s – --install-path ~/umbrel
also, make sure that your ~/umbrel/ folder is empty before running the installation script:
sudo rm -rf ~/umbrel/*

I hope this time it’ll work out!

Hey @Marcaday, I followed your steps, but still no luck, here is the Pastebin link…please note this community chat doesn’t allow me to paste a link Pastebin but the reference is: 2v4JF46S

Hi @Marcaday, is there a way forward with Ubuntu or should I be looking at an alternative installation Operating System? Thanks.

I checked your last pastebin. It appears that the issue is that your were installing in Windows using WSL. This could be causing issues and errors:

Either use Docker for Windows, as the post above says, or (better) install on bare metal (using Easy2Boot or Rufus [Rufus 4 and 3.22 didn’t like Ubuntu server 22.04 so I used YUMI which worked great]) or a burned dvd. This assumes that you have another PC, and this older one will be your dedicated Umbrel server.