How to run Plex through Tailscale

I recently ran into an error after the newest Plex update where I was no longer able to get remote access through my Plex. I have been using Tailscale and trying to get as many apps comfortably working on it as Umbrel, as of yet, has no https functionality.

After a bit of research I was able to get Plex to run exclusively through Tailscale with these steps:

  1. Have Tailscale setup and know your vpn ip for your server.

  2. Make sure to have remote access disabled on Plex.

  3. go to Plex webview and enter settings > Network.

  4. Under Custom server access URLs, type the servers Tailscale IP 'http://:32400

  5. Save Changes

  6. Done

Hopefully this helps anyone else who runs into this error.