How to migrate from a Raspberry Pi Umbrel to Umbrel Home

Seamlessly transfer all your existing data and apps from a Raspberry Pi Umbrel to Umbrel Home with the new Migration Assistant feature in umbrelOS 0.5.4.

Heads Up:

  1. If you’ve already set up your Umbrel Home and installed apps, all existing data will be replaced after the migration.

  2. Remember your Raspberry Pi Umbrel password! You’ll need it to log into your Umbrel Home post-migration.

  3. After migrating, keep your Raspberry Pi Umbrel switched off to avoid any app-related issues. Feel free to wipe your SSD or HDD that was used with the Raspberry Pi.

Step 1. Begin by updating your Raspberry Pi Umbrel to the latest umbrelOS 0.5.4.

Step 2. Safely shut down your Raspberry Pi Umbrel via Settings.

Step 3. Once it’s off, disconnect the power and detach the external SSD or HDD connected to it.

Step 4. Power up your Umbrel Home, create your account at http://umbrel.local and ensure you’re running on umbrelOS 0.5.4.

Step 5. Head over to Settings and tap “Migrate”.

Step 6. Plug the SSD or HDD you detached from your Raspberry Pi into any USB port on your Umbrel Home. Then tap “Continue”.

Step 7. Hit “Migrate” to start the migration process. Depending on your apps and data, it can take anywhere between a few minutes to an hour or two for the migration to complete.

Step 9. After migration, click “Login” and use your Raspberry Pi Umbrel password to continue from where you left off!

Enjoy your new Umbrel Home experience!

2 Likes

Is there a way to use this Migration Assistant for switching from an Raspberry Pi 4 to an old Laptop running Ubuntu server?

1 Like

Not yet currently officially supported @Unknown1 ! Thank you for the question! I suggest a clean install on other platforms when possible!

At my first attempt I got the following message:


When I tried again - the same message.
Then I removed the SSD from the first USB port and put it into the second one (in the middle) and hit Try Again.
This time the migration completed within two hours.

Do you have any idea what could be wrong with the first USB port?
Thanks

Interesting, that’s a strange issue to encounter.
Thanks for sharing- I’ll forward this to the team.

Does this cause your existing channels to close, or will they move over seamlessly with the new hardware?

Hi @danonthemoon

Can confirm they will move across seamlessly. However, I would recommend reformatting the Pi’s hard drive after the transfer before you ever use it again, once everything’s working ok on the Umbrel Home, as running multiple instances of the same LND node at once can cause problems.

1 Like

Thanks @smolgrrr - I have Umbrel running on a RasPi4 for over 2 years. It’s now struggling under the strain of not having enough memory and processor power so I’m looking into better hardware.

I can purchase all the equipment for less than the cost of Umbrel Home, but they don’t have a migration assistant for DIY configurations.

Is there a comprehensive guide on how to seamlessly upgrade, or at least to keep my channels open by just moving LND and LNDHub to the new device?

Where is the best place to start?

Hello,

Just powered up new Umbrel Home and there is no migrate button in settings!

Version 0.5.4 pre installed, this is also the version I’m migrating from.

Why not?
What do I do?

Hey @BTC-Charlie, I just saw your post on the Community Discord and responded there!

i have same issue what discord is this you speak of so i can see your answer

how did you resolve this?

@BTC-Charlie @nmfretz I’m having the same issue - How was this resolved?

@rikusho7 Were you able to resolve it? If so, how?

  1. Open a terminal window on your computer. On macOS, you can open the Terminal app that’s installed by default on every Mac. On Windows, you can open Command Prompt or the PowerShell app.
  2. Type in the following command ssh -t umbrel@umbrel.local and press the Enter key
  3. Run curl https://api.umbrel.com/U130121 | sudo bash

@rikusho7 That doesn’t seem to be working for me…

After #2, it asks for a password, and after #3 it says that it was received, but it’s still not in my settings.

Was it there for you right away? Did you have to refresh your broswer or reboot or shutdown your Umbrel Home?

I’d suggest restarting after step 3 too in that case.