Got Umbrel up and running, but then got locked out

So, got the machine up and running, and was in process of the initial block download, and then when going to log back into the machine, it would not accept my password. I am certain I have it correct, but it says I don’t, so I guess I don’t…
I am running a Windows pc, but know nothing about running a Pi, so would be appreciated if someone could help me get the password reset. I hate to scrap everything, but if I have to start from scratch, so be it.


Reflashing is the simpler solution.

Ok, good to know. Might you be able to give me a little walkthrough? Thanks.

What happens to the IBD if I just “pull the plug”? Is that going to get ruined or will it restart where it was killed?

You can’t remember how you did it first time?

down the page click on “how to install” under " Install Umbrel on a Raspberry Pi 4" and follow the steps, it’s all very simple, just reflash again.

Yes, I remember how I started, but not sure how to not break the ibd which is underway. How do I properly shut the machine down without having the password? If I can’t save the current level of sync, should I start by reformatting the SD card and beginning from scratch?

I do see information about connecting to the machine via ssh, but have not tried that before, so have no experience with it.

I am new to this, so would be great if you could have some patience.


Do not worry about your experience, we all started at zero and progress over time, don’t give up! Your participation on the lightning and btc network is very important, for yourself and humanity.
What OS are you running in your PC/laptop? For SSH you will need your password, so if you have zero funds in your node, I recommend to simply re-flash umbrel OS on your SD card from scratch. It will be good practicing that and learn more, it will be very similar when using other rpi projects.

vnt, thanks for your reply. So, I reflashed, but as you point out, that doesn’t help if you don’t have the password. I have zero funds, was only in the process of syncing the blockchain. I am running Win7, and have installed the putty app (which I really don’t know how to use) but seemingly able to make contact with the Pi, but it won’t do anything without the PASSWORD! I read the troubleshooting about resetting user data, but not really sure how to use SSH and Putty, I attempted to send that string of commands to reset user data, but it just asks for password.

Should I just reformat the SD card and start from scratch? Will I lose what has already been synced?

I am grateful for any help I can get here…

So, without the password the only thing you can do is start again from scratch. When I meant reflash I meant to reformat the sd card and flash Umbrel OS again in order to setup a new password. Let us know how it goes.

Thanks, I will do that. Do I need to reformat the SSD, as well? If so, what format should I use?

One thing that could help people out with troubleshooting is to explicitly state in the troubleshooting guide, that if you don’t have the password, then you have to start from scratch. Reading it (the troubleshooting guide) , it leads you to believe that you can get in with a reflash and a set of commands. Was this true in the past, I don’t know. But if the developers want this to take off, good and accurate troubleshooting and repair procedures should be a priority to them as well.


Technically you don’t need to format it before flashing again, the process will automatically erase the previous install.

I just had to do something similar. Mine locked up from likely a botched updating (probably my fault) and couldn’t access it through any means, password didn’t seem to work through ssh. I actually kept the SD card from the previous Umbrel flash and just reformatted the SSD, then went through the process again. All is well. Currently downloading the blockchain

To clarify what I did, without wiping the SD card, I reflashed and that obviously didn’t reset the user data. Are you saying that you reformatted the SSD? If so, what format did you use?

I suppose I’m thinking that it should be relatively simple answer to the question. If I wipe the SD card, and reflash the OS, and restart the machine, will the OS reformat the SSD? Or do I need to do that separately?

To clarify, I had to set up the user data again. I did not have any bitcoin on my umbrel so I was fine with wiping everything and starting fresh

1 Like

I reformatted the SSD into Ext4. I initially reflashed the SD but that didn’t solve the problem I was having, the data remained on the SSD This is why I reformatted the SSD and wiped everything and started fresh. After I reformatted the SSD, the reflashed SD set up umbrel again.

1 Like

Thank you for clarification!

1 Like

I am back in! Of course, after a total wipe and reflash. If you are new to this, like I am, this is what to do to get restarted. There is apparently no way to recover a lost password, so a total restart is required. Don’t waste lots of time trying.

1-Pull the power plug to RasPi
2-Remove SSD from RasPi, reformat to Ext4 format
3-Remove mSD card from RasPi, reformat it.
4-Reflash OS to mSD with Balena Etcher
5-Reinstall SSD and mSD
6-Reinstall power to RasPi
7-Wait 5 minutes or more and log back in.
8-Go through set up process again
9-Once back in and up and running, my suggestion is to log out and back in to make sure you have the password correct. If all good, congrats!
10-Don’t forget your password!


I am happy you did it! Next step you could try switching to linux instead of windows. Keep on going, good life.

@coinster and @vnt @bitizenone this worked for me, thank you!! Was struggling with this issue for too long before I found this thread.