Fresh Install on old device

I used to run a node on my argon m2 case with a 2280 1TB sata ssd on a raspi4 8gb. I have tried to re-install the entire setup by just wiping the sd card and flashing a new copy of umbrel on it but the data on the ssd does not get erased when I try to do a setup. Instead of showing me a fresh install screen where it says “welcome to your umbrel” it just boots back into where the previous install was. I am using balencaEtcher for flashing and got a satechi card reader just to make sure im flashing the os correctly.

You need to delete ALL the partitions on the SSD, you don’t have to format the SSD. You can see all the partitions on the SSD by going to Disk Management in Windows. Be sure to select the correct SSD, you can be sure by disconnecting the SSD, and refresh the window, and then reconnect the SSD, the window should refresh with the SSD and its partitions.

1 Like

by any chance is there a way to do this via mac? or maybe even rpi os? dont have access to windows

Yes, you can use the Disk Utility for the Mac.

In the Finder , choose Go > Utilities, then double-click the Disk Utility icon . (Disk Utility is located in the /Applications/Utilities folder.)

If you need any further information:

I hope that’s what you’d need, as I use Windows, so I’m not that familiar with Mac’s.

1 Like

thank you. yes this works!

1 Like

just one last Q. do i need to format to ex-fat or fat?

Actually, you don’t have to format your SSD, but if it keeps insisting then use FAT, so then the Umbrel software will format the SSD to the way it’s supposed to.

i tried everything. eventually got a sabrent m2 sata case. flashed the ssh into FAT. and now it works great.