Fixing Plex's 'Not authorized' Error

This post is for users who are met with a “Not authorized” error when trying to set up the Plex app. This is a known issue with Plex across all platforms that can arise unexpectedly during the setup process.

The Issue

After installing Plex and linking your account, you might see this error screen saying that you do not have access to this server:

The Fix: Claiming Your Server

The solution is to claim your server with a specific claim code so that it is linked to your account. Please follow these steps:

  1. Access your Umbrel device from a Terminal
  • For Raspberry Pi and Umbrel Home users, please follow these instructions to SSH into your device: SSH instructions

  • For custom linux users, if you installed Umbrel in a different location than the default home directory, you must replace ~/umbrel in the commands below with the correct path to your Umbrel installation.

  1. Obtain a claim code
  • Go to and copy the claim code provided.

  • Plex gives you 4 minutes to claim your server after generating this code. If you don’t claim it in time, don’t worry, you can just refresh the page to get a new code.

  1. Prepare the command
  • In a text editor, copy and paste the following command, and replace <paste-your-plex-claim-here> with your actual claim code. Make sure to remove the angle brackets (< >) as well.

    sed -i 's/VERSION=docker/VERSION=docker\n      - PLEX_CLAIM=<paste-your-plex-claim-here>/' ~/umbrel/app-data/plex/docker-compose.yml

    As an example, if your claim code is claim-ejLdcJc9uyvBhwRzTqdK, the command you would run is:

    sed -i 's/VERSION=docker/VERSION=docker\n      - PLEX_CLAIM=claim-ejLdcJc9uyvBhwRzTqdK/' ~/umbrel/app-data/plex/docker-compose.yml

    Note: it is important that you include the / at the end of the claim code. If you remove it, the command will not run.

  1. Execute the command
  • Paste your tailored command into your SSH session and press enter.

  • If the command runs without feedback, you’ve succeeded. This is what your Terminal will look like:

  • If you recieve an error message in the Terminal it means that the command was formatted incorrectly. Please follow the troubleshooting steps below.

  1. Restart Plex
  • Finally, restart the Plex app from your Umbrel’s homescreen by right clicking on the Plex app and selecting “Restart”.

    Note: if you are still on a version of umbrelOS earlier than 1.0, you will need to restart the Plex app from the SSH terminal session you are in by running this command:

    sudo ~/umbrel/scripts/app restart plex

You should now have access to your Plex Server! If you are still met with the “Not authorized” error, please follow the troubleshooting steps below


If you are still having issues, there are three likely culprits:

  1. Incorrectly formatted command
  • If you receive an error message in your Terminal like this one then the command was formatted incorrectly:

    In this example, the / was left off after the claim code. Please check that the command is written exactly as shown in the main instructions section.

  1. Multiple successful commands to write the claim code to the docker-compose.yml file, but the claim codes weren’t valid or there was a typo
  • You will need to first delete any claim codes that you have already added. To do this, run the following command in your SSH session:

    sed -i '/PLEX_CLAIM/d' ~/umbrel/app-data/plex/docker-compose.yml

    There is no harm in running this command multiple times (you may have to run it multiple times if you have added the claim code incorrectly multiple times). You can check to see if there are any claim codes in the docker-compose.yml file by running the following command:

    cat ~/umbrel/app-data/plex/docker-compose.yml

    If there are still claim codes in the file, you will see lines that look like this:

    - PLEX_CLAIM=claim-ejLdcJc9uyvBhwRzTqdK
  1. Expired claim code
  • If you took too long to claim your server, the claim code will expire.
  • Follow the instructions to remove a claim code shown in Troubleshooting step (2) right above this one.
  • Refresh the page at to get a new code.
  • Follow the instructions again for adding the new claim code

If you are having difficulties with the above steps, please reach out to us at our official support:


Nice one thanks

1 Like

This does work for me, thank you!. I opted to manually add the - PLEX_CLAIM= line below the - VERSION=docker line. Worked the same way. Thanks!

This works great!

This does not work anymore, at least for me.

Verified working for me last week./

not work for me.
“not have access”
You may be able to claim it by choosing “Open Plex…” from the Plex menu in the macOS menu bar or Windows system tray. For more troubleshooting tips, see our support article.

did you find a solution to this?

I have updated this guide to provide clarity on how to run the command to add your Plex claim code, as well as added new instructions on how to restart the Plex app from the Umbrel homescreen in umbrelOS 1.x

Let me know if anything is confusing and I can make updates.

I used this guide to setup my Plex Server on Umbrel. Very helpful. After this, I ran into the issue of the media server showing up as “indirect” on my PS5. I managed to dig into it and find the solutions and put together a comprehensive guide for the problems I faced. I’m new here, but I’ll try to make a stand-alone guide here in the community as well! Thanks!

Embedded link:

1 Like