Error: The version of UmbrelOS on your microSD card is not compatible with the version of Umbrel on your external drive

Hey Ya’ll,

I need help logging into my Raspberry Pi 4. I am unable to login on the device as the keyboard doesn’t seem to have power. I have tried another keyboard that I know works but no luck. Tried reflashing the OS etc. And finally tried writing remote access to the SD but it is not writable for some reason. Would like to be able to get the keyboard working if possible. Any ideas?

Hi @Finn, just to confirm, have you tried logging into your Pi Umbrel remotely? If you follow the instructions below you should be able to access the Pi from your laptop/computer without being connected directly to the Pi.

I can see your comment from the other thread too- leave the SD card in the Pi while you’re trying this

Really appreciate the help smolgrrr. I entered the password and received this output. “Connection closed by 2601:348:4100:5010::1171 port 22”

Ended up reformatting the ssd and was able to login. Just going to redownload the bitcoin blockchain and start over. Thanks for the tips though.

1 Like