Channels gone after recovering node

My umbrel node crashed. I was frustrated and decided to start from scratch again. I swiped my mini sd and flashed it again and also swiped my SSD (dumb move, but that what happened) . I d/l the timechain again and after two days it was back and up and running. I recovered with 24 words and my onchain funds are visible. My latest channel backup is from before I opened my last channel. In my lightningnode app on umbrel I went to the three dots top right and clicked on restore channels. Here I uploaded the latest version of my channel backup. My channels are not visible and my lightning wallet shows 0 sats. When I check RTL there are no channels visible. I do know which channels I have and looking in 1ML I see the channel ID’s. Also, I can get in touch the owners of the channels that I have. If I ask them to close, will the sats go to my onchain wallet? Is there a way to restore my channels?

Is chantools an option in this case?

I had the same problem recently and eventually had success using the guide below which sounds pretty much like you describe, but with a few extra points.

  1. I had to work out, with eventual success through trial and error which of backup files was was the current one just before the crash, this is the one that worked.

  2. Once it did have the correct file it force closed all the channels and returned the sats on chain, not as it shows but didn’t lose anything, just had to start again.

  3. I did find the Lightning Node app kind of glitchy when sorting through the backups in that sometimes it would show you the files and other time wouldn’t, i just kept opening and closing the app and eventually got there.

Good Luck!

Thank you, the problem is that my channel backup is not recent. It is from before opening my last channels. I tried using cat ~/umbrel/logs/karen.log | grep 'backup ID' | tail -n 1 in powershell to get my latest channel back but that didnt work since I get a weird output on that command (^M). So I am still stuck with this problem. Thanks for your reply though.