Missing Umbrel Lightning Channel Backup

Hello everyone,

I wanted to go through the process of recovering a lightning channel from scratch before allocating more liquidity to my primary node.

So what I did is I setup a second umbrel node and opened a 1 million sat channel. I saved the channel backup file from Ride the Lightning and proceeded to wipe the SSD and SD card,

I successfully restored my onchain balance using the 24 recovery words but haven’t been able to recover the lightning channel. I tried using the RTL channel backup but it isn’t working – and I didn’t realize you could download a channel backup from the Umbrel dashboard itself before I wiped everything.

I want to try restoring the lightning channel using the channel.backup file generated by Umbrel but I don’t have it. However, I am told that an encyrpted version of the channel backup is synced directly to Umbrel’s servers.

I would like to request a copy of that backup if it’s available. Can someone on here help with that? Thank you in advance. Here is the public key for my node: 0310a30b0fe3f62b2763040e3723066540f27b7d52b106bd1bb9d888370bba44ae

If you have the channels-all.bak (I think that is how it is named) file from RTL, you can still initiate the backup procedure, but it is just a bit more complicated.

You have to make a new folder called \restore in your umbrel @ \umbrel\app-data\ride-the-lightning\rtl\backup with the mkdir command

After that, you can copy your .bak file to that location, RTL should then give you the option to restore from that file.

1 Like

Guide for non Linux users would be nice. If I have backup file in my phone or PC, how can I copy it to fresh Umbrel? Handling with files in terminal is my nightmare🙈 I miss old good M602 or Volkov Commander.

Not a linux user either, I was forced to work it out because that was the only way I had to recover my funds!

Anyway, the step-by-step on this is essentially (this is off the top of my head, as I can’t currently SSH to my node, but I am pretty sure I’ve got it all right):

  1. SSH into umbrel@umbrel.local
  2. Enter Password
  3. Use the command sudo mkdir -p \umbrel\app-data\ride-the-lightning\rtl\backup\restore
  4. Open a new PowerShell window or Terminal (pointed to your local machine), or use cd to return your existing terminal/powershell to your computer
  5. Use the command scp <\path\to\your\channel-all.bak> umbrel@umbrel.local:/home/umbrel/umbrel/app-data/ride-the-lightning/rtl/backup/restore to place your RTL backup in the correct location
  6. Go to RTL - Click Lightning - Backup, then move to the restore tab. The “restore” button should be available now (previous to these steps above, it would have said you needed to create the directory and place the file there, and would not allow you to press the button)
1 Like

Very happy to report that this worked. Thank you!

Hi I am also trying to restore my channel backup using rtl. I tried the command lines from fireworksurprise, but somehow I’m getting the message of “permission denied” (please see below). Can you tell me what I need to do or doing wrong? Thanks

1 Like

I am running into the same problem. Created the folder, but when I try to script the .bak file onto the node I receive “Permission Denied.” Please post if you’ve figured out a solution because I haven’t found one.

Hello… can someone help me with this? The only backup I have from my channels are the RTL backup…
Apparently I managed to transfer the file… but it still not showing in the restore tab in the RTL app. Did the directory changed with any updates? Can someone help me, please?