Can't SSH into umbrel

I’m on the latest version 0.4.2. Using a Raspberry Pi 4 B and a 1TB SSD. Device is connected via Ethernet to router.

I did the initial setup, changed my password and synced the blockchain completely. Now I try to SSH from a Windows 10 machine (connected to router via wifi) using PowerShell and I get “Permission denied” always.

I tried logging via umbrel@umbrel, umbrel@umbrel.local, umbrel@[IP address] and using default password and new dashboard password.

I also tried using “ssh -t” as someone on reddit said it helped. But nothing works!

I couldn’t try connecting my laptop via Ethernet to the router since I don’t have the necessary adapter, but I think that’s not necessary?

1 Like

Login into your node using SSH session is ONLY from another PC / device and is done using a terminal.
From windows 10, yeas you need to use Powershell.

You can reset your user data (only if you do not have any funds in that wallet/LN channels) following the instructions from Umbrel Troubleshooting Guide and start over.
No blockchain data is lost, only that you will be prompted to create a new user and save a new node seed 24 words.

1 Like

Thanks, but I finally I figured it out.

The problem was I was pasting the password, and apparently ssh doesn’t like that. You have to type it out character by character for it to work. Now I can SSH. Thanks again, anyway!

1 Like

Need help!
I am unable to connect to the node via ssh from windows 10.
Node is running fine.
I just cloned the ssd from 1 tb to 3 tb and now wanted to run ssh for growpart.
But keep getting permission denied when I try to connect (ssh) to the node.
Please help!

Did you check if you IP intranet changed?

try some software like remmina to make ssh easier.

Thank you for your response vnt. Now I am able to ssh in the node. Someone at twitter educated me to use ssh umbrel@umbrel.local (I was doing ssh username@umbrel.local).

But now I am facing another problem.

My new SSD is 3 tb in size, but it is not reflecting the new size (it still shows the old SSD size). In other words, now I am unable to growpart.

Any ideas?

1 Like

I also can’t connect to my Umbrel from local network right now.
I was changing some lnd.conf before it happened.

It says:
ssh: connect to host port 22: Operation timed out

I also can’t see mDns umbrel.local domain in my network.

Ping to umbrel machine is responding correctly.

I ran ufw before, to open port for lnd, but probably I blocked ssh by mistake.

Can you guys help my to fix it?

I have physical access to rpi now and I have external keyboard, but I don’t have micro hdmi converter to connect display.

If I connect keyboard to umbrel, what should I type to login terminal?

sudo ufw allow ssh[enter]

Will that be correct? Can someone check it for me please?

I guess it´s very hard help you design a new kind of node, here. That’s a matter for developers.

1 Like

I am just trying to access ssh, but it is not working, and I don’t know why.

did you ever find a solution to this? i’m having the same problem. I enable ufw and it seems to have blocked my ssh access :frowning:

sudo ufw allow ssh

No, I reinstalled my node and moved to raspiblitz which is better if you are not 100% noob I think.

1 Like

This is not solution, when you can’t connect to node and type it.

same as me I was doing ssh username@umbrel.local !

1 Like

Did you solve it ?