Cannot access umbrel

I followed the steps to install Raspberry PI5 on this site to the T but I cannot access umbrel.local
I’m using a new micro SDcard 64GB, a new 2TB SDD, connecting to my network: Eero with a TP-link 8 switch.
I cannot see Umbrel in the Angry IP nor in my Eero app.
I’ve tried formatting the Sd card and retried the install, no luck.
Any advice would be appreciated, thanks.

Have you tried connecting the Pi directly to your router to see if that helps?
Also, may I ask the make and model of your SSD?

If I connect directly to the Eero, then my PCs wont have Internet access, since the Eero only has one port.
The SSD is a Seagate STX.

I tried to ssh, and “No such host is known.”
Also, when I plug in the Raspberry, after 5 minutes of the fan running, it stops and light goes red. Is that normal?
One more thing. Should the SSD be empty at this point? Mine is.

I bought a new Micro SD Card and a new SSD, and a new power supply.
Retried, and it works. WHo know what is was, but it works.