BlueWallet (Mobile)

BlueWallet


bluewallet

Available for: Android, iOS
Official website: https://bluewallet.io

Instructions

On-chain

  1. Open BlueWallet on your phone, tap the three dots to access the settings and go to Network > Electrum Server.

  2. Tap Scan or import a file.

  3. Open the Electrs App. It should show 100% synced, and look like the image below:


    Scan the <Electrum Server QR code>.

    You can enter manually <Electrum Server URL> for Host and 50001 for Port.

  4. Tap Save and restart the app.

Lightning

BlueWallet uses LndHub to offer multiaccount features on your node. It is not an application to control your node, and access your whole balance. LndHub will actually use your node to receive and send payments, but each wallet balance is internal to LndHub and is not known by your node. That means if you spend directly from your node and not using BlueWallet, you can move funds “belonging” to LndHub wallets. Learn more about how that works here.

  1. Install the BlueWallet Lightning app on your Umbrel.

  2. Open BlueWallet on your phone, tap the three dots to access the settings and go to Network > Lightning Settings.

  3. Tap Scan or import a file.

  4. Scan the QR code displayed in the BlueWallet Lightning app on your Umbrel.

  5. Tap Save and restart the app.

  6. You can now create new Lightning wallets in BlueWallet, that will use your LndHub and your Umbrel as backend.

Congratulations! You have successfully connected BlueWallet to your Umbrel.

2 Likes

These instructions do not include where to go within Umbrel. Ever since the recent release of Umbrel into a “home server” from a BTC/Lightning node nearly all these procedures have changed.

2 Likes

Hey @LVONM! With newer versions of Umbrel, you can find the electrum server QR code directly on the Electrs app UI, apart from that, it seems to me that the procedure is the same.

2 Likes

Is it needed for Electrs to be 100% synchronized? I currently get that BlueWallet can not connect to the Electrum server.

Yep! BlueWallet will not be able to query your Electrum server if it is not fully synchronized.

Cool, thanks for the speedy reply!

1 Like

It works now when I use the tailscale IP address of the node. Tailscale magicDNS doesn’t work for some reason.

This is something I have investigated personally as I couldn’t seem to get BW to connect to my node over TailScale after having a bad time with Tor (Thanks iOS!)

After some digging I discovered that Tailscale recently changed the MagicDNS Tailnet format from beta.tailscale.net to ts.net - Bluewallet does not allow http clearnet connections without being whitelisted first.

I have since issued a PR to Bluewallet to include ts.net in the list of exceptions for their android & iOS apps respectively, which has recently been merged - so once they rollout the next set of updates this should work. :+1:

1 Like

Awesome! Good to know they will change their domain format

I have BlueWallet installed on Umbrel. I have it installed on my iPhone. Now I have several Sats wallets and BTC wallets. Now I want to manage funds so that I have Sats on my wallet funded by my Bitcoin LND Hub. But how should I do that…?

Hello, i tried this process but at step 3 i have error message ‘can’t connect to the provided Electrum server’.
I use Blue wallet on android 8.0 and Umbrel with Electrs fully synced on Ubuntu LTS 22.04.1

Question : in general Umbrel settings, do i have switch on remote tor access ?

Thanks

Hi, noob here.
My LNDHub does not have Node URI. Somebody help?

There is some issue in on chain mode:

If you running your node in tor protocol, you need to go in Settings>Network>Tor Settings and turn on the disable button. You also need to use Orbot app and select the blue wallet to start on VPN mode.

“Invalid LNDHub URI”

Has anyone gotten this error when trying to scan/import a file in the lightning settings?

1 Like

Hi, I did all the steps, and I am not able to see any channel open in my LND Hub from Umbrel.
Therefore I cannot send funds from any of my LN wallets of my BlueWallet through my Umbrel LND Hub
Any ideas?
Thanks

I have the LndHub, Lightning Node, Bitcoin Node, Electrs all installed in Umbrel. Bitcoin and Electrs are synchronized and up-to-date. The block height is synced in LndHub as well.

I have successfully connected BlueWallet on my iOS device to my Electrs via its Tor address.

The error I am receiving when trying to connect my BlueWallet to the LndHub is when I tap “Scan or import a file”. It successfully captures the QR code, but the address is:

http://not-enabled.onion

This seems odd. I also typed in the long ass node uri and that didn’t work either. In the picture, I see that there is 1 active channel. Must I have an active channel before I can connect the BlueWallet? Or is there some other criteria that must first be met this is giving me the above “not-enabled.onion” error?

I have the same problem, do you have already a solution? :slight_smile:

Unfortunately I do not. I have read these:

when following those steps, I always receive the http://not-enabled.onion error in the “Lightning Settings” of BlueWallet. Perhaps @DarthCoin may have some troubleshooting ideas since he seems to have helped people in the past with similar issues.

I have installed and tried Orbot, but that didn’t make any difference. Another note is that I had no trouble setting up my Eletrs with BlueWallet and it shows connected.

I have also looked at the docker containers for lndhub, bluewallet stuff, and tor, and lightninglabl lnd and it appears everything is exposing the proper ports. Is it possible that I am getting some generic QR code and not my specific one?
Is it possible to just restart the LndHub “service” through Umbrel? I’d prefer to not restart all of Umbrel, but also don’t know all of the docker pieces that LndHub is using underneath.

I resolved it, deleting from my node the app LNDhub BlueWallet Lightning and re-installing it, but now I have another issue that is when I try to update the LN wallet in the mobile or create an invoice from the mobile generate the next error: API error: bad auth (code 1)

1 Like

I had the same issue but I’m using bluewallet on iOS. In BlueWallet, settings, general, I turned on “Legacy URv1 QR” and it seemed to resolve the issue. I always have remote tor access on in Umbrel, but I’m not sure how/if that would affect connection to BlueWallet. I’m guessing it needs to be on.

Good question.