BlueWallet Electrum Server Can't Connect

Hello, thanks in advance for any help!

I’m trying to connect my BlueWallet to my Umbrel node. I went to Connect Wallet → BlueWallet and followed the instructions. Steps 1-5 went well (connecting the Lightning Hub). However, the latter steps didn’t go well as I couldn’t connect to the Electrum Server. Below is what the default looks like:

When I scan the Umbrel QR code for the Electrum Server, the first field populates with a Tor address (a long hash followed by .onion). The second field is filled in with the default port. The third field is left blank. I’ve tried a few combinations of ports (blank vs default) and nothing is working. I keep getting, “ALERT: Can’t connect to the provided Electrum server.”

Has anyone run into this or know a solution? I’d really like to connect my node to my BlueWallet.

Thank you,

Have you activated TOR in the Bluewallet settings? The first line must contain the address…onion.
In the times line 50001
and the third line remains empty

I just gave it another try without changing anything for the several-th time and it worked!.. hmm lol.


Having this issue persistently. Any fix?

There are 2 ways to use BW with Umbrel node:

  • connecting to LNDhub Bluewallet Lightning app in Umbrel. Here you have a guide
  • only using electrum server from your node to validate your onchain txs, but for this connection go to connect wallet - electrum and use that onion address in BW. Remember to activate Tor service in BW (if you use latest version) or add BW into Orbot (if you use an old version of BW).

Optional use: using the 24 words seed, you can import the AEZEED Umbrel wallet into BW, just as a backup onchain.

Yep. I’m using both. However, for other wallets I want to use in bluewallet such as hardware, the electrum server isn’t working. Persistently fails to connect. Not sure why.

Update: I found the issue, at least for me. The electrs docker is restarting constantly in a loop, making it inaccessible. Any ideas how to fix this @mayank or @lukechilds?

1 Like

Interesting! @entreprenewer can you please get us logs of your electrs container if it’s still crashing? You can get them by SSHing into your Umbrel and running:

cd ~/umbrel
docker-compose logs --tail=300 electrs

Thanks so much for the fast reply my friend!

Here you are:

It’s like, 50 pages :wink:

Thanks for the logs, Jon! Looks like filesystem corruption. Can you please try reindexing electrs by running:

sudo systemctl stop umbrel-startup && sudo rm -rf ~/umbrel/electrs/!(electrs.toml) && sudo systemctl start umbrel-startup

Then wait for one day (to allow electrs to reindex) and try connecting your BlueWallet to your Umbrel (or any wallet that supports Electrum) and see if that makes any difference.

On it, will report back. Thanks so much for the exceptional support my friend :slight_smile:

1 Like

Since doing that, I’ve had major connectivity issues, going down constantly as if I were still on 0.3.12, every few hours.
Oddly enough, when I get back online, it syncs the blockchain, but then goes down again - and then when I restart /power cycle, it starts again at 690,939, as if it wasn’t connected the last few hours between outages.

This MAY be because I tinkered with other settings, but I don’t think so. All I did was try to get charge-lnd going in another docker, and I installed some python setup tools.

I’ve now flashed SD card, and let’s see if that works.

I am having this same issue as well. Any ideas how to fix this?
Also I am not sure if it is related, but when I try to send to my Umbrel node lightning network wallet I get error “does the receiver have enough inbound capacity”.

Actually… I just tried whole process trough again… and it worked suddenly!
This was like 10th times I tried it… I did not do anything in different way really.

If someone have idea how to try to debug this I am happy to provide logs or any other info.

Same problem here as well (except that 3.014 mentions

Fyi, i tried to connect the wallet about 30min-1h after the sync to bitcoin was done 100%
Will try again tomorrow.

Just flagging I have been experiencing the same issue. Every now and then it will connect, but usually the status is “Not Connected”, or “can’t connect to the provided electrum server”

using iOS bluewallet

Anyone close to a fix for this? Alternatively are their other iOS wallets people can suggest that work well with umbrel?