Blockchain reindex or wiping off everything?

Hello there, I am a new node operator since two weeks (raspberry pi4 8Gb, 1TBSSD, recommended box and originial power supply), I had some funds on the onchain wallet and some channels opened on the lightning. But then I had problems when first upgrading to Umbrel 0.5.0 OS (wallets were blank after the upgrade). Also, I think I had done something bad at lnd.conf file when I was setting my alias.

So I decided to wipe my node (both mSD and SSD) and to start over again, because I wasn’t finding a solution. Previously I made sure to have my seed phrase and channels backup saved.

Wanted to install 0.5.0 OS but at the configuration it wasn’t showing where to put my seed phrase and I was uncomfortable with that, so decided to downgrade and start it over with 0.4.17 (I still had the copy on my PC). Entered the old seed phrase, all good. I was expecting to find some sats on the onchain balance but they weren’t there, but told myself it’s ok because blockchain was downloading from the beginning and maybe they’ll become visible once it will reach 100%.

So I first gave my node an alias (and this time the lnd.conf file wasn’t compromised like it was at my first attempt, I can confirm, also ThunderHub is showing the name I gave it) and then started to follow the point 1 of this guide How to restore your node wallet (Using standard, normal way using a new instance of an Umbrel node) to close the channels and everything worked fine, saw some sats flowing in the onchain wallet.

Fact is that after one day there were still some sats missing, so I decided to continue my research in the guides and found out that:
1- I maybe have done the mistake of rebooting the node after the new blockchain download was started, so maybe the process of lnd has stopped working and I will need to reindex the blockchain (if I understood correctly);
2- I also read that it is suggested to not reimport the old seed phrase on the new node setup (btw, I’m on the same hardware as before, don’t really understood what you mean by “set up on a new instance”… raspberries are too expensive by these days lol) but I don’t know why.

So I downloaded Bluewallet on my phone and imported the seed and in fact I can see more sats than in the umbrel wallet.

Now I’m asking for a suggestion, what should I do now?
Reindex the blockchain once it has finished downloading hoping that the full balance onchain will come out (matching the one I see on Bluewallet), or wipe everything off (apart for the blockchain) to obtain a new seed phrase, before starting opening channels again?

Thanks in advance

Someone please?

Blockchain is now at 100%, not seeing my whole balance.
Tried a small deposit, not seeing my whole balance even after this attempt.

Please guys, I want to be online again with my channels :slight_smile:


What does your lightning node do? Can you post here what the following are giving?
tail -f ~/umbrel/lnd/logs/bitcoin/mainnet/lnd.log
cd ~/umbrel && docker-compose logs -f bitcoin