Bitcoin node not accessible after syncing blockchain

I just set up Umbrel on a Raspberry Pi 4 and finally after 10 days finished validating the entire blockchain. Therefore, I was thinking now my node would be active and I could connect to it from my wallet application on another computer (Wasabi).

Unfortunately, I don’t think Wasabi is able to connect. I go into Wasabi -> Tools -> Settings and under Network: Main, I enter my Bitcoin P2P Endpoint as: umbrel.local:8333

Now I also have ssh’d into my umbrel and docker exec’d into the lncm/bitcoind:v22.0 container with:

docker exec -it <container-id> /bin/sh

In there I run bitcoin-cli getpeerinfo and I see one entry with "inbound": true but it is a local IP of

I have set up a DHCP IP Reservation for my Raspberry Pi in my router and also enabled port forwarding for 8333 to that device. However, I tried to test external connections using and entering my external IP and port 8333. It says it is unreachable.

I am able to access the Umbrel web page via http://umbrel.local and I have enabled 2-factor auth.

What I would like to do is ensure I can connect locally so I am trying to configure Wasabi to use my umbrel node but it does not seem to be working. Am I putting the correct hostname and port in my Bitcoin P2P Endpoint value?

Is there some way I can send a test transaction using curl or some app that can send appropriate bitcoin protocol messages to Umbrel from another computer in my network to confirm it is working? I also tried telneting and it seemed I was able to connect: telnet umbrel.local 8333. I also tried calling JSON RPC methods with curl (over port 8332) but that did not work even if I allowed traffic over port 8332 in my internet router.

Umbrel uses Tor, not IP. Every app has a Tor address for external conections.
You can config Umbrel to use IP, but then it allow external conections (inbound), but RaspPi is not enough for that.

Set a static IP for your node and also set that IP in your host file local machine where you have Wasabi
Read here

So on, should I enter the TOR address that is shown on the Umbrel page?

For example:

And then in the port box, still enter 8333

I also tried that still says it is unreachable.

The issue is not that I cannot reach http://umbrel.local from within my network. I can log into that and see the bitcoin node status, my apps, etc. I can also ssh into the umbrel using ssh umbrel@umbrel.local. The issue is that I cannot seem to connect to the bitcoin core node specifically. I do not think it is an IP / hostname issue.

You said you changed router configs, unchange that, no need for Tor.
The endpoint address is format xxx…xxx.onion:8333
You can look local IPs here: You can have lots of fun messing with it…

You said you changed router configs, unchange that, no need for Tor.

I don’t understand… I am running Umbrel on a raspberry pi inside my network. How would it be accessible to the outside world via Tor or anything else via port 8333 if I did not open that port in my router and forward traffic from that port over port 8333 to my raspberry pi running Umbrel?

Also, bitnodes is still unable to access my node via my Tor URL (.onion). I got this Tor URL from Umbrel’s Settings page under the “Tor” section.

I also tried removing my port forward rule for 8333 in my router and that still made no difference.

OK, I think my confusion here was just about Tor. I am unfamiliar with it.

It seems Umbrel is set up to route all external traffic via Tor. The advice I saw for reserving my node’s IP and setting up port forwarding was from the bitcoin core documentation so I think that led me a bit astray.

So as I understand it, I should be accessing my node within Umbrel via Tor only, not directly via my IP and port 8333.

I am still not quite sure why bitnodes cannot reach my node via the Tor URL though so that’s a bit of a mystery.

I use Tor Browser to access Umbrel, is very good (no need to use Orbot in this case). I have problems when using Orbot with Firefox or other common browser.