Bitcoin Node Cache Size Not increasing

I have the RPi 4GB version. I’m syncing the blockchain, I think I did 90% in roughly 4 days but this last 10% is extremely slow. I’m not sure if it might be because of the ordinals and somehow more data has to be downloaded?

Anyways in trying to improve the syncing speed, I made sure the SSD 1TB was plugged in the USB3.0, I have an ethernet connection as well. I went in the settings increase the Cache size from 450MB to 1800MB. I made sure to save and restart bitcoin node but it doesn’t seem to change anything.

The RAM usage is about 700-900MB which is odd because that’s higher than when I had it on the default 450MB.

Also, not sure if it’s related but my number of peer connections seems to fluctuate a lot and can’t keep 10 peers for more than 10 min.

CPU temperature is very stable at around 45-47 celsius

1 more weird thing I noticed but a bit off topic, my blockchain size is 591 GB but when I got in Umbrel settings it says bitcoinnode is taking 655GB

it does that, There’s more going on later in the chain. Don’t be surprised if it goes 1% a day.
Its also sorting. So your RAM will fluctuate. as that’s where it stores things before it writes to the disk.
Its moving and writing and organizing and verifying and and and and so the size will go up and down until its finished,
Very important not to mess with it right now unless you want to take the chance of starting over.
Just leave it alone.
As far as that ram thing do not go over about 1/2 of your total ram. You need some for system etc.

What you are doing when you change the size of the RAM at this point is making more room for more of the chain to be sorted at once. So when you restart its going to start again at zero and build until it gets to your maximum as you stated about 1.8 gb and then its going to dump that to the disk and start with the next chunk.
It should be ok to get electrs started but dont go installing 100 things and uninstalling and turn off and on and unplugging and going crazy or you are going to have a bad time.
Patience my friend.
And thank you for helping secure the chain.

Thanks for the reply my dude!

It finished today! Actually the RAM usage started increasing very slowly. I increased the max to 3GB although it never reached the max it was syncing way faster! It just takes a little while after a restart to increase RAM, or at least for me. The big difference was the CPU temperature but after placing it next to the window in winter I had all the cooling it needed for the extra load.

The size is still a puzzle for me, blockchain size is 615GB while in settings bitcoin node takes 685GB.

Also I restarted the RPi several times and never got any issues syncing.

there is more to bitcoin node than just the blockchain.
Be sure to swap your ram back as it has no benefit after syncing.

Curious to know what other the data is keeping.

Yeah I’m planning on doing so, currently I’m leaving it as is because it’s actually really cold I don’t know what’s the minimum temperature for the CPU but I saw it go as low as 30 celsius.

you can take a look here is the bitcoin directory. There is probably things elsewhere but here is the bulk

Open up a command prompt and ssh into your umbrel node.

here is a command to run

du -h ~/umbrel/app-data/bitcoin/data/bitcoin

that will spit out the information you seek