Bitcoin App Starting but nothing

I have upgraded to 1.0.4 i believe today.
I finally can access the dashboard or through SSH again.

I have tried the stop script, and deleting the settings and peers file, and restarting script.
I have also tried to backup the peers file.

Neither seem to be working.

Any ideas how to get up and running again?

1 Like

@expatsam could you got to Settings > Troubleshoot > App > Bitcoin and then download the logifle and upload it here please.

Is there anything container in the file that can’t be shared publicly?

No it’s safe to share but you can also DM it to me if you feel more comfortable.

Hey guys,

I am having the exact same issue. I am running the latest version (1.0.4) on Raspi.

I have tried the following:

  • Restarting Bitcoin Node app
  • Restarting Umbrel
  • Shutting down Umbrel and restarting
  • Reflashing Umbrel
  • Downloading transmission and uninstalling (seemed to work fine, but didn’t help Bitcoin app issue)

Still same issue. Here are my Bitcoin Node app logs:

umbrel_bitcoin_2024-03-28_07-54.log (109.2 KB)

Here are my Umbrel OS logs:

umbrel_umbrel_2024-03-28_08-09.log (125.0 KB)

Notably, I see this in the Bitcoin Node logs:

bitcoin_bitcoind_1   | 2024-03-28T12:53:53Z Error: BerkeleyDatabase: Error 22, can't open database wallet.dat
bitcoin_bitcoind_1   | Error: BerkeleyDatabase: Error 22, can't open database wallet.dat

Any help would be great. Thanks in advance!