What's the need for backups?

I’m not really sure if I’m backing up properly.

Do our recover seed words give us access to our lightning wallet, channel status as well as our BTC node if needed?

Why do we need to backup lightning channels and how often should we be doing this? Can we set it up so it backups automatically?

The procedure for restoring from backup is explained here Frequently Asked Questions (FAQs)
The channels backup is necessary when you open new ones or close ones. That backup file will save the “status” of your channels and will close them in case of recovery procedure, moving the funds you had in them into your onchain wallet.
The seed for your Umbrel wallet is the one you should keep it safe and use it to restore in case of SHTF.
Optional you can use that seed into Bluewallet to import your onchain wallet and manage the funds.

1 Like

I tried this but did not succeed. I tried by choosing ‘import wallet’ in my BlueWallet app. Then I entered the 24 words and confirmed my wish to import. Should I have done anything else? The wallet that shows up in BlueWallet is empty. It is certain the 24 words were correct and the onchain wallet in Umbrel has sats in it :slightly_smiling_face:

If the seed is correct, it should show up the balance. But if the channels are still in pending closing… you have to wait

There are no pending channels. Maybe someone else can try if importing the wallet into BlueWallet (on a smartphone) succeeds? In my case it obviously does not. As far as I can tell this won’t succeed for anyone.

I imported successfully the node wallet into BW using the seed. I even made a tx with coin control from a UTXO that didn’t showed up in my node (sending back to another address from node).
BW is importing perfectly AEZEED wallets.
So is something wrong with your seed.
That’s why I always do this test: any new wallet I create, in any wallet app, first thing before sending funds I test it. To see if the recovery works well. Just importing in another app or in the same app, and checking if are the same BTC addresses generated. Once you’ve done that you are good to go funding, because you are sure you recover the right one and works.
This a golden rule of Bitcoin.

Thank you very much for trying this out. There is only a small amount of satoshi’s on the wallet currently. I will fix my revovery setup before anything else.

I checked and re-checked the seed that is provided by the Umbrel dashboard. Also BW recognises it as AEZEED HD (but it generates different addresses). Is there a passphrase used when Umbrel creates the wallet?

No, just the 24 words.

Good god this has got me worried. Am I able to recover funds using my 24 word seedphrase or not?

My funds are sitting in the btc address on the block explorer, I tried Blue wallet, I set up a ledger with the seed phrase but I still can’t recover my funds.

Please explain what I am missing!


Umbrel uses a LND wallet, that is an AEZEED format. That means that only another LND wallet can recover it. BW (Bluewallet) and Blixt wallet uses LND wallets and can recover your wallet from that seed.
Both uses SPV so it will sync on your mobile a bunch of small blocks. That will take a while so be patient until it will show up.
If you used the correct seed, IT WILL SHOW UP.
I tested myself with BW, I could even be able to do txs from the same wallet.

Hi DarthCoin

Can you help guide me on how I get the backup file onto my Umbrel?

I’ve followed the troubleshooting and your other post.

The one thing I can’t work out is how to get my backup from my laptop to the umbrel.

A little nervous as I had a lot of funds in channels and I bricked my SDD (a western digital passport that must have got corrupted with power failures). Replaced all the hardware now but looking forward to reassurance that I’ll get my funds back…


Thanks DarthCoin

I found that - but I’m struggling with a more basic step.

I can’t seem to find the path back to my laptop. It puts Umbrel as the root.

My path is /Users/[username]/downloads etc. It doesn’t recognize that path. If I add the root by putting ~ /Users/[username]/downloads etc. it looks for /home/umbrel/Users/[username]/Downloads/ etc.

Sorry I know this is elementary - I’ve been looking through navigating linux guides but still am struggling to get the path name while I’m in Umbrel for some reason.

Sorry - ignore this. I realised now that I’m not meant to SSH into umbrel before running the first command