Wallet seed not working to recover wallet

I tried to import my on-chain wallet in BlueWallet by filling in the 24 words. It did not succeed. Also this procedure does not succeed: https://openoms.gitbook.io/lightning-node-management/technicals/restorelndonchainfundsinelectrum.

The resulting wallet in BlueWallet or electrum is empty, while the wallet in the dashboard holds satoshis an shows past transactions. Also I can send and receive with this wallet. There are no channels in the pending state. So this is worying: if something goes wrong, my seed will not work to recover the wallet.

@DarthCoin pointed out there is probably something wrong with the seed.

What can I do? It is important to have a working recovery procedure. Is it possible to create another wallet to fund channels with? Or should I close channels, send the bitcoins to another wallet and start over with a new Umbrel installation?


Electrum do not restore AEZEED wallet. Only Bluewallet.
I pointed you to use the FAQs of Umbrel where is explained the procedure to restore your channels and close them

Sorry, I think we have a misunderstanding. I am the person of this thread and you did not point me to the FAQ :slightly_smiling_face:

The channels are up and running and functioning OK, so I do not think the channels need restoring. Also I can send and receive with the wallet. The only problem is: the wallet will not be recoverable if things should go wrong in the future.

My question is what steps to take to have a node with a wallet that can be recovered, should things go wrong.

It should be working to import in bluewallet.
I did it and worked perfectly. I was even making a tx from BW with some UTXO that wanted to move.
That was the idea actually, to use BW and the seed in case of SHTF.
Try again and be sure you put the right seed. You can see again the seed in Umbrel Settings, maybe you write it wrong first time.

OK, I will try again.
When I import the onchain wallet into bluewallet I get a choice between three types of wallets: ‘Bitcoin’, ‘Lightning’ and ‘Vault’. In my attempts until now I have chosen ‘Bitcoin’ each time. Now I see the choices I start to doubt: should I pick ‘Lightning’ instead?

I did it again, very carefully, from the words given from settings. It tried both ‘Bitcoin’ and ‘Lightning’ but for importing that does not seem to matter. The result is the same with me again: Bluewallet accepts the key but shows an empty wallet:

Thank you very much for mentioning Zeus. I looked at it and I will probably start to use it.

However, my current problem is the fact that I don’t seem to have a seed that will recover my wallet, should in the future things go wrong on the node. My question is: what I can do best now to arrive at a situation where I have a seed that will recover, if ever needed?

Hi Brie,

I am having exactly this issue but with significant funds and in my Umbrel BTC wallet only (not in LN).

I lost access to my node and am trying to recover my funds by using the 24 seed phrase. Blue wallet, Electrum, Ledger, they all accept the seedphrase but show 0 funds.

Did you end up finding a solution?


It is starting to look worse now. I have dug further into electrum and when I search for the transaction to my Umbrel wallet it comes up as “transaction unrelated to your wallet”.

Did I write my seedphrase wrong then? No, 100% no. I found I wrote down the seed phrase 2 times on completely different occasions. Once when I started my node and once when I put significant funds in my node’s BTC wallet. Months apart, exactly the same.

I’m at a loss. Is it in any way possible that the seed phrase I was provided via the node was wrong?

Hi Melvis. Yes, I found a solution: I installed lnd on a laptop (plain lnd; so not using Umbrel). In the ‘lncli create’ step one gets the option of entering the 24 words. It was accepted and it recreated the right wallet with the funds, that could then be sent to another wallet.

In order not to have to download the full blockchain, I used neutrino. Neutrino currently is not safe for a full running production node, but can very well be used for the purpose of having lnd to recreate the wallet. Please ask me if you need extra information helping you out.

I was inspired by https://docs.lightning.engineering/lightning-network-tools/lnd/recovery which I printed out and read multiple times. After adapting it to my personal setup I now have a recovery-procedure in place which I practice and test regularly.

In my case my seed phrase had been right all the time.

Hi Brie,

Mind letting me know how you restored your funds?


Melvis, I restored it as described above: I installed lnd on a laptop and used the seed in the ‘lncli create’ step.

I was having the same issue. Try creating a transaction in BW AEZEED imported (node) wallet then in the top right corner, the 3 dots, select Coin Control. Look for UTXO and see if it’s your node onchain balance. I was able to select this, then when I went to finish the transaction I had to select Use Full Balance and sent to my node again. (set high enough Fee, I didn’t see option to enable RBF)
Looks like BW bug? obviously I didn’t have 0BTC balance…

Hello everyone,

I am also having the same issue. I have tried to put my 24 seed phrase into BW and it show no funds and no transactions even though I added funds to by nodes btc on chain wallet. Can anyone point me in the right direction?


You could try also with Zap desktop (not mobile) using the seed.

1 Like

I can confirm that this works! Thank you Darth.

The simplest I found is the convert the Umbrel seed (24 words in AEZEED format) into the master private key that can be imported in any Bitcoin wallet.

This conversion is easy, use https://guggero.github.io/cryptography-toolkit/#!/aezeed, download the page on your computer and cut the internet to do the process offline: in “Decode mnemonic” section input your Umbrel 24 words. The value of master private key “HD node root key base58” can then be imported into most Bitcoin wallet like Sparrow Wallet.

1 Like

Yes, I tested this method and works 100% perfectly! Thanks for pointing it out!
I included into the guide for recovering Umbrel node wallet

Hello there, I restore the seed phrase on BlueWallet.

When in Umbrel I tried to get an new address ( clicking on Deposit botton) I can’t see it from the 25 available address on bluewallet. Is that correct ?
Many thanks