Upgraded my umbrel node to 0.4.10 now node is stuck

Hello guys,

I upgraded my umbrel node to 0.4.10 and now I’m stuck at 99.92 or 99.93% syncronizing.
I tried to SSH into my node and run this command:
rm -f ~/umbrel/statuses/update-in-progress && sudo reboot
but doesn’t seem to have helped

I have debug logs that I’ve seen other people post. I can post the whole thing if it helps.

Can someone please help figure out what’s wrong?

= Umbrel debug info =

Umbrel version


Flashed OS version


Raspberry Pi Model

Revision : d03114
Serial : 1000000035baff2f
Model : Raspberry Pi 4 Model B Rev 1.4


Aug 3 2021 18:14:56
Copyright (c) 2012 Broadcom
version 40787ee5905644f639a2a0f6e00ae12e517a2211 (clean) (release) (start)



In the Bitcoin page, do you have connected peers? If hours on did pass and no peers, you can try to do some restarts. If it persist, you should use a fixed IP. Look the guides in this site.
I just put a reserved IP number in my router dhcp, and had no more problem to get peers. But now can only access Umbrel typiing the IP number :thinking:

I do have peers connected but still stuck at 99.92%

You need one “in”, I guess. Only suggestion I can give is to fix a IP

thank you. I’m a total noob and don’t know how to fix the IP.

I found this: How to set a static IP for your Umbrel machine

But I can’t understand the instructions. I don’t know what to do after I run this command: sudo nano /etc/dhcpcd.conf

static IP didn’t help. trying to re-index the blockchain now.

What you did? Reserve a IP in the router? Restarted RPi? Without “in” connections you can’t go on.