Update SD card to latest umbrel version

My node won’t update to the latest Umbrel version via the GUI, nor via ssh.
It runs the update for 30 seconds and the returns to the homescreen.
The update is still available and trying to install it, gives the same result.

What would happen if I update the SD card to the latest release?
Will my channels still be intact?
I have installed some additional scripts? Will they be gone as well?

We wrote a troubleshooting manual that is there to help users with cases like these. Did you read it?
There’s a special section there that explain exactly what you have to do in case of stuck update or if you want to manually update.
Re-flashing the mSD card is also an option, user data will not be erased, no worry, all data is on SSD. But also could be some other components stuck so see the manual about that.
First, yes try re-flashing.

I did all of the above.
Even tried flashing the SD-card.
No idea what to do next

This is shown in the logs!
Schermafbeelding 2021-11-23 082254|297x258

For some reason the new version isn’t triggered to run