Unable to install btcpay-sever

I’ve installed umbrel os on my raspberry pi 4 with a 2TB HDD.

only thing I did differently was instead of connecting rpi to an ethernet cable I connected it to wifi. Because of that docker wasn’t installed on the first boot so I later installed it manually using sudo apt install docker.

Everything works, IBD is happening as expected. Only problem is every time I install BTCPay Server from the store it gets stuck at “installing”.

To debug I ssh-ed into my rpi and tried installed btcpay server manually like this: ~/umbrel/scripts/app install btcpay-server.

This is the output:

umbrel@umbrel:~/umbrel $ sudo ./scripts/app install btcpay-server
Setting up data dir for app btcpay-server...
sending incremental file list

sent 160 bytes  received 16 bytes  352.00 bytes/sec
total size is 2,595  speedup is 14.74
Pulling images for app btcpay-server...
Pulling nbxplorer ... done
Pulling postgres  ... download complete
Pulling web       ... done

ERROR: for postgres  failed to register layer: error creating overlay mount to /var/lib/docker/overlay2/87d10fe1ad0e511cb430087b36c330e082c0e31b33e9443429952e6594ce776c/merged: too many levels of symbolic links
ERROR: failed to register layer: error creating overlay mount to /var/lib/docker/overlay2/87d10fe1ad0e511cb430087b36c330e082c0e31b33e9443429952e6594ce776c/merged: too many levels of symbolic links

Docker version: Docker version 20.10.12, build e91ed57

I’m not sure why this is happening. I’ve tried reinstalling docker but it didn’t fix it. How should I fix this? Are there any more logs I can provide?

GitHub issue: https://github.com/getumbrel/umbrel/issues/1263

Did you ever login into your Umbrel and click that button to install BTCpay?

Why complicate things when are so simple?

hey that was the first thing I did. On doing so Umbrel would get stuck at “installing” for hours, and if I refreshed the page I would find out it wasn’t installed.

This is why I inspected in the first place.

Did you try to Remove and re-install?

from GUI? no it never registered as installed, so i can only click on install and have it stuck on installing.

from terminal? yes. I’ve used the same ./scripts/app uninstall script to uninstall and reinstall btcpay-server.

I get the same issue everytime.

Yes, you need to uninstall clicking the EDIT button in the Umbrel installed Apps page

i do not have btcpay-server installed because I’m unable to install it.

If I click on install from app store I don’t get past “Installing”.

which is why I tried installing from terminal in the first place.

are you on 0.4.15? do you have a 1tb hd? reading your post i wanted to try and install it. was able to with no problems. maybe restart your umbrel via the gui. then try and install.

@dackdel running 0.4.15 with 2tb hdd. i’ve already tried restarting from gui. doesn’t fix it.

@DarthCoin @n080dy is there a way i can reinstall umbrel all together without having to redo IBD?

Yes, if you are using a Rasp Pi device, just re-flash the mSD card with the latest Umbrel version and plug it back, then start Umbrel.
Done

@DarthCoin i reflashed my sd card and the issue is there :frowning:

weirdly when I first installed umbrel directly on top of raspbian (not umbrel os) then I was able to install btcpay-server (but it wasn’t detecting my HDD so I thought I’d rather just install umbrel os).

and now umbrel os wouldn’t install btcpay-server.

Perhaps they’re more logs I can provide to further investigate?

@DarthCoin I reformatted my HDD. Reflashed my SD card. I’ve setup a fresh new umbrel and doing IBD again.

I’m still not able to install btcpay-server. Same issue.

maybe it has anything to do with my HDD?

EDIT: I retried again after some time and it worked. yay.

for anyway reading this later, this is my analysis:

what I did incorrectly was on my first boot I didn’t connect my raspi to the router with the ethernet cable. Instead I wanted it to be connected to the wifi so I booted it directly without internet. I connected a monitor and keyboard and logged in locally.

The default password was “moneyprintergobrrr” and username “umbrel”. I’m assuming because I didn’t allow umbrel to connect to the internet on first boot it wasn’t able to install dependencies like docker. I configured my WiFi from terminal and then rebooted.

Umbrel was missing docker so I did a simple “sudo apt install docker” and boom umbrel was working. But I wasn’t able to install btcpay-server. The root cause is still unknown but I suspect its docker and has to do with the failed initialization on first boot.

This time I made sure to do the first boot with ethernet cable connected to my router and things worked out.

If you wish to connect to WiFI on first boot this is a solution I recommend:

  • instead of Balena Etcher, use the raspyberry pi imager.
  • select the umbrel os ISO under custom OS.
  • press ctrl+shift+x to open advanced settings
  • enable SSh and WiFI from there (raspberry pi imager will do the configuration on its own before first boot)
  • start umbrel, it should connect to wireless WiFi on first boot and initialize properly.

tyvm. @DarthCoin @n080dy @ dackdel

1 Like