Unable to access Github.com to upgrade my node


I a trying to run:
cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.5.3

but get an error

What can I do to fix it?
Screen Shot 2022-11-16 at 9.02.14 AM

I see that I am able to download v0.5.3 from https://download.umbrel.com/umbrel-os.zip Do I need to change my path in the command?

Thank you,

  1. check that you have a resolv.conf file in the /etc directory
  2. issue command ‘sudo nano /etc/resolv.conf’
  3. add the following entries for 2 public DNS resolution services at beginning
  4. save resolv.conf (Ctrl-O then press Enter then Ctrl-C)
  5. run ‘ping github.com’ again and see if it resolves now

@swizly12 @DarthCoin
I edited the file and opened it twice to confirm my changes were saved.

Screen Shot 2022-11-16 at 2.09.22 PM

…below is what I see when I try to ping.

Screen Shot 2022-11-16 at 2.08.21 PM

@DarthCoin @swizly12

I rebooted my node…
waited a few minutes
Then ran the following command:
cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.5.3

…but is seems to have failed… please see attached image.

Difficult to diagnose from afar. Try steps recommended here, we already tried resolv.conf but maybe your firewall settings are wrong. I assume of course your Umbrel device is connected to a network with Internet Access.

Yes, my node is connected directly to my iMac and I can see my node from umbrel.loca.

I will try the link now. :slight_smile:
Thank you

@swizly12 that article is good for a different domain.
I need the github.com nameserver to add to /etc/resolv.conf

I think I found the solution!!

ran the following command from iMAC terminal and now I can ping GitHub.com:

echo github.com | sudo tee -a /etc/hosts

Now I will reboot and try the upgrade with the following commands:

rm -f ~/umbrel/statuses/update-in-progress && sudo reboot

cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.5.3

Wish me luck! :crossed_fingers:t5:

NEW ERRORS: :sweat:

Any insight on this? @swizly12 @DarthCoin

Thank you

I have google fiber. They have no firewall and are not blocking anything.
hmmm …what can I do?
Still stuck. None of the manual instruction that I have found in this community are working. @DarthCoin @swizly12 @getumbrel_admin Any help?

hmm your setup is strange. Normally you have a router that is connected to your Internet Service Provider and all your devices are connected either via cable or WIFI to that router. You seem to have your umbrel device connected directly to your iMac and not a router. What is the iMAC conncted to ?

iMac is connected via wifi to Google Fiber. I have 1000 GBTS upload and download with Google and no firewall.

@swizly12 @getumbrel_admin @DarthCoin what is the best way to get support …I can set up a zoom meeting if that helps? @admins

I fixed it! :partying_face: :partying_face: :partying_face:

I literally plugged my Node into my Netgear Switch via Ethernet and was able to access it from SSH on a computer on my network.

I now have the current version and experience writing SSH terminal commands.


THANK YOU @swizly12 for support me, and thank you Jim in support.

1 Like