Umbrel Troubleshooting Guide

I saw the, “Noooo! Do not do that again? You already did enough damage.” pop up on my notifications and it made me laugh out loud. Thank you for your help. I will do that. I appreciate all your help. I can follow those simple instructions.

If you already initiated that recovery of funds and you have all channels closed and funds back in onchain… there is no need anymore for that old node id. Forget it.

1 Like

@DarthCoin After updating to Umbrel Version 0.4.15 all my sats are now showing in my Bitcoin Wallet, so I do not need to run the command you provided previously. Thank you for all your help.

1 Like

This was a life saver, thank you. As a note, I had to add the peer on the uploading node before it would add to the peer list

Hello Darthcoin, thanks for your useful guides!
I restored my umbrel due to the neef of updating to a bigger SSD drive. After introducing the seeds and once downloaded 100% of the blockchain, I still dont see my bitcoin funds. I followed your troubleshooting on " I restored my Umbrel node from seed but my balance is zero" two times with no success.
Just to verify: when introducing this command { sed -i ‘/reset-wallet-transactions=true/d;’ ~/umbrel/lnd/lnd.conf }, is one or two separate commands? should i expect to see any reaction on the command promt?

Before doing such a big move, why you didn’t read carefully my dedicated guide or at least ask here first?
http://community.umbrel.com/t/how-to-restore-your-node-wallet/
There’s a section 7 exactly for this where is explaining how to move to another hardware.
There’s NO need to use the seed!
Now you messed up things more.

You will need first to let the node to resync 100% and let electrs to finish the index, then start the restore from seed + backup.
After that you need to wait up to 144 blocks until all your channels will be closed and funds back.
THIS PROCESS TAKE TIME! Have patience please, before doing anything else.

Hello Darthcoin, thanks for your time. In fact I´ve been very patient.
Some months ago I already read many of your fantastic guides, since I had an issue with some corrupted blocks reported on the logs, so I tried to perform at that time the restore of my node following the same guide you sent yesterday.
However, maybe due to my lack of technical knowledge (it is a big effort to me to type on the command prompt…), at that time my node did not restore correctly. The umbrel community helped me realize that I needed to to update my SSD, because its capacity was 500 GB and was not enough. Since I live in Venezuela, It took me a couple of months to import a compatible 1 TB SSD from the US. When i received the new SSD, I introduced my old node seed, and started syncing the blockchain.
My situation now is that i have all the blockchain 100% synced, but both btc and LND wallets still show synchronizing message. This is the reason why I tried to follow your “I restored my Umbrel node from seed but my balance is zero” guide.
Here you have my logs: https://pastelink.net/rgjewh6o
So now I just have to wait? I have no issue for waiting, i just want to know if there is anything else i have to do. For instance, I don´t know how to check if electrs has finished the index…
Sorry for my lack of expertise… I hope I’m not bothering you…
Regards

Is it explained in the troubleshooting guide:
cd umbrel
docker-compose logs electrs

And see at what height of blocks is still indexing.

In regards your logs it says very clearly:
lnd | 2022-05-06 01:38:21.583 [ERR] RPCS: [/lnrpc.Lightning/GetInfo]: wallet not created, create one to enable full RPC access

So you didn’t restored correctly or the process didn’t finished.

I suggest to reset the whole instance and start over with a new node instance, new seed new wallet, clean.

Old wallet, if you had funds in it, restore it in Zap, BW or Blixt (see the specific situation in the guide about restore dead node).

Thanks. I will follow your suggestion this afternoon as soon as i get home. Just a fast question: when reseting the whole instance with a new node instance, new seed new wallet, will I have to download again all the blockchain or I could use the one that it is already downloaded to my new 1Tb SSD?

No, check in the troubleshooting manual the section where is explained. All blockchain data remain.

1 Like

Maybe make this bold, I didn’t look carefully enough to see that 0.4.8 is NOT the same as 0.4.18, and I ended up rolling my node back a whole bunch of versions and in the process losing all the apps that didn’t exist back then :wink:

Hahaha good that you realize that. It should be ok just updating the correct version.

I think is wrong, it should be: sudo ./scripts/start

Also, for stop, it should be:
sudo ./scripts/stop

sudo ./scripts/start or stop is for non-RPi users.
sudo systemctl start umbrel-startup is for RPi users.

@DarthCoin Clarification question on watchtowers to check my understanding. Is their purpose to “watch” one’s lightning node/channels when one’s lightning node has temporarily gone offline only? If this is correct, then is it helpful to run a watchtower on one’s umbrel lightning node “watching” that same umbrel node’s lightning node/channels? I would assume not, but I am not sure of all that the watchtower does. Are there some other benefits to doing this?

A watchtower monitors the bitcoin blockchain for any transaction attempting to steal from its client by closing a channel with a previous, invalid state. If a breach is found the watchtower immediately broadcasts a punisher transaction moving all funds in the channel to the on-chain wallet of its client.

If there are two nodes in your control from lnd v0.7.0 you can set them up to look out for each other. Best to be done with nodes in two separate physical location so any unexpected loss of contact can be covered for.

1 Like

No worries. I’m out. It will be disappointing to watch the project die a slow death, but that’s what happens. You’ll learn.

What will you be using rather than Umbrel?

I’ve had way too many issues trying to just get it to work without crashing a week later.

The community is rather helpful, but it does have a Stack Overflow vibe that makes you not want to ask for help. I think that one thing this community should understand is that most of the Umbrel users are not super tech savvy and simply want to help secure the Bitcoin network and using some of the cool lightning features.

If one of the Umbrel overlords sees this, please don’t chastise me too hard.

1 Like

I’m actually running citadel anyways, but my main complaint was you attacking Darth.

I am facing a problem in your OS that hasn’t been mentioned in the guide, comments, or any kind of troubleshooting.
After running the OS, it doesn’t start downloading the Blockchain automatically and when I troubleshoot the system finds no problems and states everything is fine.
What’s the solution?