How can I change my Username?

Hey, i reflashed my Umbrel node because i was having problems with it randomly switching off. When I booted up I made a mistake with my username please could someone help me with changing the username as there’s no option in the UI settings


Not yet implemented on the user interface, but as Umbrel team reported, will be implemented soon.

It is not possible to do so from the UI yet. If you don’t mind use the terminal, you can SSH into your Pi:

ssh -t umbrel@umbrel.local 

(The password is your dashboard password)

Then run:

echo "$( jq '.name = "NEWNAME"' ~/umbrel/db/user.json )" > ~/umbrel/db/user.json

Don’t forget to change NEWNAME by your new username.

Be careful running this command. This file contains your hashed password and seed. Copy paste it and change only NEWNAME.


 echo "$( jq '.name = "louneskmt"' ~/umbrel/db/user.json )" > ~/umbrel/db/user.json

Thanks So Much!!! You’ve been super helpful


I cant seem to get this to work? Copy pasting with only the name changed? Any ideas ppl? Cheers

Struggling to get this to work, I keep getting the error “Permission denied” when trying to run the echo command.

Is there a step I’m missing, am I supposed to log out of the web interface or will this not work whilst Bitcoin Core is still syncing?

What’s the exact output?

Ah so, it seemed to be a permission problem with changing the user file. Can’t recall the exact output.

So I did some reckless tinkering, where I used chmod to change the file permissions, edited in vi then changed the permissions back.

Almost 100% certain this isn’t a sensible way to solve the issue but it “works” now. (Despite probably compromising the security or reliability of my setup now?)

Thank you. That worked for me. After I typed it all in and hit Enter, on my first try all i would get was a new line waiting for something. I did a CTRL+c to stop whatever I started and at the command prompt, I started again and realized I had one typo. Fixed the typo and it worked perfectly.

By the way, I am really a newbie on Debain (and Linux in general). When I ssh in using the Command Prompt via the default Terminal app that came with Windows 10., I can not copy from a website (like this) and “paste” the verbiage on to a command line. I’m sure there must be a way - I just don’t know how to “paste” verbiage from the clipboard on to a command line in Terminal screen in Windows.

Hi Lounes, trying to use the command above, but I get an “access denied” message.
I’m running latest Umbrel version on a Raspberry Pi4 and using Terminal (macOS) to connect via ssh.
What could be wrong?

Can you send the exact output of the command please?

Thanks. My mistake, the error displayed is “Permission Denied”. Here is a screenshot. You will note that I have logged in into “umbrel@umbrel-3.local”, as this a third node running on the same local network, so had to change each node’s network name. You think maybe this causes the issue?

You right click the top bar to access the menu and enable copy/paste in Properties.

I’m having this same problem. Any solution?

Hi again Lounes!

I somehow managed to overcome the “permission denied” issue, and now I can see that name has been changed to “Gaia”. The image below displays the info.json file, which shows new name (Gaia) and 3 apps I had installed before changing the name (lightning-terminal,ride-the-lightning & thunderhub)
Screenshot 2021-11-22 at 11.15.13
However when I connect to Umbrel via browser, instead of asking for my password, the UI shows that I have to enter my Name, password etc, as if it was a fresh install…
(To be more precise, for a split second the “enter password” field appears but then immediately disappears…)

I have tried clearing browsing history, restarting the Node and browser several times but still I get the same… What could be wrong?

Thanks in advance

Why are there a lot of new lines between the start of the file and the first { ? Try removing them. If it doesn’t work, please send me your logs.


I have no idea about the lines and don’t know how to edit the info.json file (tried to type “edit user.json” but get this:


umbrel@umbrel-2:~/umbrel/db $ edit user.json

perl: warning: Setting locale failed.

perl: warning: Please check that your locale settings:

LANGUAGE = (unset),
LC_ALL = (unset),
LANG = “en_GB.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to a fallback locale (“en_GB.UTF-8”).
Error: no “edit” mailcap rules found for type “application/json”

How can I edit the user.json and what logs should I send you & how do i retrieve them?

(sorry for all this but first time in my life I use SSH and have absolutely no idea how it works…)

You need to use the command

nano ~/umbrel/db/user.json

Use the arrows to navigate and delete all the new lines, so the first line of the file is {

Then save the file using the shortcut Ctrl+X, then type ‘y’ (without quotes) and hit Return.

Thanks, I did it. But still when I open Umbrel from a browser it acts as if its a fresh install

Hello, I’m trying to change my username using this code but i get this message:

-bash: /home/umbrel/umbrel/db/user.json: Permission denied

What can i do?