Umbrel Stuck on recovery page

Hi all,

I have been running Umbrel for over a year. I had a few lightning channels open too. After an update, my lightning and bitcoin wallets got stuck in synchronising. I tried turning scripts off and off using ssh, but that didn’t help. As I had backup channels and seed words, I decided to reset the user data. Upon restart, the umbrel got stuck on recovery page. Can anyone offer any suggestions? I am new here and not a professional. I can access umbrel via ssh and am posting my debug log as well before the reset of user data for anyone to help.

Many thanks in advance for your time.

Mac mini M1 chip
Raspberry pi 4
Ethernet connection

Version 0.4.10 is bugged, should not be used. I don’t know if you can downgrade, so you can do a clean install with version 0.4.9 (exclude SSD partition) or wait for releasing of version 0.4.11. Both cases you´ll have to reflash SD card to the desired version.

Thanks a million. I will give it a try. Hopefully, one of them will fix the issue. I wish I had known that before allowing umbrel to update.

Does anyone know how to downgrade?

Ok. But remember doing a clean install will loose all, including lightning channels. So, before exclude sda1 partition, copy to another disk the channel.backup file, to do a funds recover later.

Thanks. I do have my seed words and channels backup already. Can I not just do a clean install and recover?

Sure, go on.

Any specific on what is bugged? I had an issue with pihole that I was able to resolve.

Any other issues I should be aware of? :joy:

Tried a complete reflash with 0.4.9. Same issue. Starter screen stuck on recovery page. Any other tips on how to recover.

Did you exclude partitions of SSD? Reflash SD card is not enough to do downgrade.

I didn’t. Any tips on how I should. :thinking:

With Windows use Disk Manager, with linux use Gparted, or SSH and do command
sudo mke2fs /dev/sda1 -t ext4

Ok. Tried that and no joy. Unable to format the SSD. I keep getting this message-
sudo mke2fs /dev/sda1 -t ext4

mke2fs 1.44.5 (15-Dec-2018)

/dev/sda1 contains a ext4 file system labelled ‘umbrel’

last mounted on /swap on Mon Jan 10 16:42:23 2022

Proceed anyway? (y,N) y

/dev/sda1 is mounted; will not make a filesystem here!

I am unable to find a solution.

Hi, Removed the partition using fdisk and the setup worked. Now waiting to recover the wallets using the seed words. Thanks for your help.

Also, would like to add that I rechecked the internet connection by disconnecting and reconnecting the Ethernet cable. Something worked. Not sure which one.

Hi all - I’m having this problem with 5.3. Tried deleting the partition, tried older versions, no luck.

When I click recover, the wheel spins forever and I never get to enter my phrase. Same if I click “next” to set up a new node.

If I click “note down later” I get the “invalid seed length” error like others have noted.

Installing on raspberry pi via windows 11/balena etcher and a 1TB external SSD. Deleted partition using the disk manager.

Replied other thread in the GitHub forum regarding same issue. Just sharing here too, to see if I get a quicker answer as this thread was more recent.

Thanks in advance!