Umbrel stops working everytime I connect my ledger


First of all, really great to see these kinds of open source projects, really like the vibes!

I’ve been syncing my node with the blockchain to 100% and I’m now trying to connect my ledger wallet to my node using the Specter app installed through my Umbrel app on the Raspberry.

I’ve followed all the required steps listed here. The thing is, every time I run the scan that looks for the ledger, I have an error that states that my external hard disk has been disconnected (which is not the case) and I have to reboot the node so I can use it again.

I’ve already allowed, in the USB settings, the connection to the Umbrel app and when I run the connection test, the result is identical.

Here is the process I’ve been following:

  1. Click on add new device and select Ledger
  2. Get via USB
  3. Connect my ledger and enter the password
  4. Scan is stopped and the node stops working.

Hey guys, any idea on how I could fix this? Still can’t connect the ledger wallet. Cheers!