Stuck at basic setup

Forgive the ignorant problem. I’ve had my Umbrel for 6 months and still can’t fix this issue no matter what I try.

I followed the instructions on the Umbrel website. The good news is core is 100% synced and I can log in no problem. However, my issue is hooking up my Ledger to the Specter wallet. I am running a Raspberry Pi and trying to access thru my Mac Book. At one point in time I had the Specter desktop app on my Mac, but I started everything over and I am trying to just get to Specter thru the app inside Umbrel. At one point in time I was able to connect to the Ledger, but that isn’t working anymore. It seems like there is a configuration file that needs to be updated? I have done the configuration of the USB for remote access and that seems to be where the first issue lies. In Specter, I am in the hardware bridge devices page. I appear to not have this setup right, as I get 2 red boxes that say “The string did not match the expected pattern” and “failed to detect devices”. If I pick “Custom” I enter what I think is the right address, but connection doesn’t work. If I pick remote, it pops up a box that says to changes the preferences in the desktop app that I don’t have running (and don’t think I need to having running?).

I don’t think this is my only issue, but this is the issue I can’t overcome.

Please be kind. I’d appreciate and “idiots guide” link to troubleshooting, but I have been searching for 6 months.


Hey @gobuffs!

My understanding is that you’re trying to use your Ledger device with the integrated Specter Umbrel app.

Either you need to use a HWI Bridge with Specter or you can use Specter Desktop directly on your computer, connected to your Umbrel. I’d recommend the latter, as it’s not easy to configure the former. IMO Specter on Umbrel is useful for watch only wallets or multisig using PSBTs.

I’m linking two posts below for both solutions.

HWI Bridge:

Specter on your computer:

I think I’m running into an issue with the specter desktop password. I installed specter desktop and when it didn’t work (well it worked further than the integrated specter umbel app) I deleted it. When I reinstall it seems to still want that password I created on the previous instance. I don’t recall that password. I can’t see to find a way to reset it. I found this but I can’t seem to get in there. I know my raspberry LAN address but it just brings me to umbel. I have tried to erase and reinstall umbel, but the specter desktop setup still seems to be in there or in my ma book

I forgot my password, how can I reset it?

Check the .specter-folder in your home folder (or on your mynode/raspiblitz/…). There is a file called config.json in there which has a line like this:

"auth": {
    "method": "somethingInHere",

Depending on "what’s written in somethingInHere:

  • If it’s rpcpasswordaspin, you can lookup the password in your bitcoin.conf-file in a line like rpcpassword=YourPasswordHere
  • If it’s usernamepassword, you won’t be able to recover the password but you can deactivate it by setting it to none
  • If it’s none (or you just set it to none) you can login without any password. So hurry up with setting it again within specter."