Umbrel doesn't start

Initially I had built out my node using Samourai Dojo. I’ve come across the Umbrel product later and much prefer the clean UI and ease of use, it looks very familiar. I’ve begun practicing on a virtual machine and would like to essentially switch to Umbrel.

I’ve installed Umbrel onto my computer running as my node box. That machine is running Ubuntu 22.04 LTS.

In the Umbrel folder I try to execute sudo ./scripts/start but receive this error message:
ERROR: for tor Cannot start service tor_proxy: driver failed programming external connectivity on endpoint tor : Error starting userland proxy: listen tcp4 bind: address already in use

What can I do here? I’m hoping I don’t have to start over and re-download the entire blockchain again and start from an empty slate.

have you tried to reflash the sd card with umbrel again? Seeing as the blockchain and user data is stored on the ssd they should be safe from being wiped. Whenever you mess around though with the the umbrel files or os. be sure to have a copy of you seed phrase and channel backup. lnd directory too if you can.

@DrWalrus, thanks for your reply.
I’m not using a raspberry pi set up, I have a Dell Optiplex 3080 Micro computer that I have installed Ubuntu 22.04 LTS onto. I control that computer via ssh on my main PC. I’ve installed Umbrel using “curl -L | bash”

Is this running on bare hardware or as a VM? It looks like you have other software installed that is using the required IP:Port. If you’re running off Ubuntu (as I am) you can either install Umbrel to the local drive or to a mounted drive. Can you give anymore detail on your setup?

I’m running Ubuntu Server 22.04 LTS on the optiplex, I’ve swapped the hard drive for a 1TB SSD. Then I followed some tutorials to install bitcoin core, fulcrum server, sparrow, samourai dojo and wallet. Everything is stored locally on that machine. I executed these via ssh on my PC, on my local network.

It seems that Samourai Dojo is using docker containers and producing errors when umbrel begins to initialize. The error message names a container in conflict, I run docker ps to identify what is using /tor and /tor-proxy containers was samourai dojo.

I’m wondering if I can swap Umbrel in there somehow, without having to redownload the whole blockchain and sync it with a server.

Did you install all of this through the Umbrel interface or as standalone individual software packages? It sounds like you’re trying to run Umbrel with other software outside of the normal Umbrel build and if so you’ll have to troubleshoot and fix all the conflicts as they occur on the system and/or in Docker.

Unless you’re extremely comfortable in Docker I would not recommend installing all this stuff separately. Just run Umbrel and install the pre-built apps from Unbrel’s app list.

Yes you can save the Bitcoin chain data but if you’re outside the normal Umbrel install it’s gonna be hard to help you on this forum.

Okay, I think I’ll search elsewhere for help then? I installed everything independently, not through Umbrel. It was complicated and challenging to do, which im proud of, ya know… but Now when I need to dig back into it, its not familiar, so I’m having difficulty.

I’m not very comfortable with docker yet, still a novice.