Can't resolve hostname, Tor doesnt start

I installed Umbrel on an r610 it was doing well, then the update. i had a static ip because it was a webserver before.after the OS was completely installed and started using the node i updated and restarted. the machine no longer would use the umbrel.local or the ip. it looks like the port says 22 instead of what i had before 24 so I dont know if that is an issue. when I start umbrel using ./scripts/start creating tor has an error. says "cannot start service tor: driver failed programming external connectivity on endpoint tor (random numbers and letters): error starting userland proxy: listen tcp4 bind address already in use
encountered errors while bringing up the project
failed to start containers
and of course i can no longer access the dashboard… i went in and reset my static ip again through netplan to the same i had before and rebooted machine and same issue.

when i try to use ssh umbrel@umbrel.local it says refused on local port 22 <----- this is my best guess on the issue, because my static ip on my router is 80 and i seem to remember it being 80 before or 24… either way this 22 seems different
that is all the information i know to give please help this happened after i opened a channel :frowning:


IP should always be set on your machine (eth card details) and not on the router (using mac address + dhcp).
You should set the static IP in your linux machine and then restart umbrel again.
After that you can access it from any other device using the IP, or if you want to use umbrel.local, just edit your local hosts file adding the IP and name desired to have for your node.
Opening a channel do not affect your IP and your channel is just fine.

1 Like

i am sorry i miscommunicated… the static is set on the machine, i did port forwarding on the router to open port 80 … the static was set using netplan.

Umbrel do not need to have any ports open. Is using all Tor.
Accessing from local LAN machines can be by IP or umbrel.local using web dashboard.

Just do manual update procedure with the latest umbrel.
See troubleshooting guide

cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.4.8 this command doesnt work in umbuntu says no such file

Then is because you are doing something wrong.
Try this, from the same machine where your Umbrel is running. Open terminal and run these steps.

  • cd umbrel
  • Stop Umbrel node: sudo ./scripts/stop
  • Update system:
    sudo apt update and then sudo apt upgrade
  • Restart system: sudo reboot
  • Update Umbrel:
    cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.4.8
  • wait patiently to finish the update
  • Start Umbrel: sudo ./scripts/start
  • Now you can enter into dashboard Umbrel. Leave the node to catch up with blocks and logs, usually takes several minutes, be patient. In special electrs service that is re-indexing latest blocks.

umbrel is not in the root directory. these are what are listed root@umbrel:~# dir
app-data bin docker-compose.yml events karen lnd nginx scripts statuses tor
apps bitcoin db electrs info.json logs templates there is a file called umbrel-os in the scripts file, i did the second part of the command and it worked sudo ./scripts/update/update --repo getumbrel/umbrel#v0.4.8

after all that it says this
reating network “umbrel_main_network” with the default driver
Creating root_app_tor_1 …
Creating root_app_2_tor_1 …
Creating root_app_3_tor_1 …
Creating dashboard …
Creating tor …
Creating root_app_tor_1 … done
Creating root_app_2_tor_1 … done
Creating dashboard … done
Creating root_app_3_tor_1 … done
random letters and numbers): Error starting userland proxy: listen tcp4 bind: address alrCreating electrs … done

ERROR: for tor Cannot start service tor: driver failed programming external connectivity on endpoint tor (random letters and number): Error starting userland proxy: listen tcp4 bind: address already in use
ERROR: Encountered errors while bringing up the project.
Failed to start containers
Skipping status update when not on Umbrel OS

why do you run as root?
you should use your regular user in that ubuntu

mike@umbrel:~$ cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.4.8
bash: cd: /home/mike/umbrel: No such file or directory
mike@umbrel:~$ cd ~/umbrel
bash: cd: /home/mike/umbrel: No such file or directory
same issue, i tried that as well that is why i went to root

so you install it as root. wrong.

@louneskmt what do you think? is time for plan B to reinstall umbrel in the right user and restore funds?
He’s using Ubuntu installation and Tor is not starting.

i appreciate any help yall are able to give, feeling pretty down about this

Is Tor already installed on your computer? Looks like Umbrel cannot start because the Tor container cannot use the port 9050.

Yes it is or was installed, I have not removed it and everything was working until a reboot. After that tor had this conflict and I don’t know how to resolve.

1 Like

Then there you have the cause. Ubuntu Tor service separate from umbrel tor service, using same port. You can configure Tor (ubuntu) to use different port and you are good to go.

Ok thanks is there a guide or link for configuring tor. I will work on that and hopefully everything works out.

If anybody ask, this is what fixed it. Apparently even though umbrel was told to shut down, tor stayed listening and was trying to open on top of. I did killall Tor command and booted right up


The killall tor fixed it for me as well! Thank you so much.

I couldn’t get Umbrel to “load” and couldn’t SSH or access web gui. Did sudo killall tor and then sudo ./scripts/start and all is good

1 Like