Umbrel 1.1 on Proxmox

Does someone installed Umbrel 1.1 on proxmox?

I am not so familiar with Proxmox but maybe this helps:

1 Like

Hi, I haven’t installed it yet. Planning on doing it later. The general steps would be.

  • Download Umrel img.
  • Copy it over to proxmox as an ISO. (if not you may need to mount it as a disk)
  • add disk where you would like to install your OS.(make sure to * boot from Umbrel disk).
  • Boot and install Umbrel.

PS:
I will try this later today and report back.

UmbrelOS runs fine on my virtual machine (Synology/QEMU).

Only issue I ran into is that UmbrelOS somehow only allocated 128MB to use for storage. I can’t even install one app. Everything else seems to work fine. Anyone having the same issue?

Trying to boot up GParted and resizing the partitions.

Hi,

I managed to get Umbrel running on Proxmox as a VM. The entire thing took maybe 15mins. My process was.

  • Download Umrel img.
  • Unzip with 7zip.
  • Write to flash drive with BelenaEtcher.
  • Pass flash drive through to MV in Proxmox
  • Set flash drive as boot disk
  • boot, select install disk.
1 Like

No luck here, just hangs of booting from hard disk after booting from USB :frowning:

@5hack what configuration did you use for your VM. CPU / Disk etc?

These are my VM settings.

1 Like

@5hack You absolute legend used wrong BIOS needed the UEFI one but i am getting a warning saying I need to install efi disk. Not really sure about this I’m new to proxmox my setup is basic is this going to be a problem

image

image

image

Okay, so I’ve just signed-up to help you (maybe lol)

Just got it working, it’s important to use UEFI (with EFI disk for uefi storage ofc) and disable secure boot:
ESC (as soon as you see the proxmox logo) > Device Manager > Secure Boot Configuration > Attempt Secure Boot - press space to remove the X

Just exit / reset and it should reboot straight into the installer

@pierreschwang Haha Thanks I appreciate that.

I did check the setting it’s already unchecked and it’s greyed out anyway.

Not sure the VM will boot even if I manage to install umbrel

I came across these threads, looks like such a ballache gonna be a long night :sweat_smile: :frowning:

https://pve.proxmox.com/wiki/OVMF/UEFI_Boot_Entries

It should boot, the EFI disk is only relevant for storing settings of the UEFI - so without one, changes are not persisted across reboots - but that shouldn’t be a deal-breaker for the installation itself (especially if your host does not support secure boot)

Ah ok well I’m pretty sure it should support secure boot.

Say hello to my little friend haha. 13900H + 96GB (Yes 2x48DDR5) RAM 4TB Samsung 990 Pro

Might work if i can get the damn thing to turn off keep getting this with VM’s its driving me nuts

Just use the dropdown button right next to “Shutdown” in the top bar and select “Stop”
Go into the hardware, remove the USB device and edit the boot order (enable the scsi drive and put it at the top)

1 Like

Yes stop is usually the one that that works if no QEMU.

SHE’s ALIVE!!! ah its been 2 years since I had an umbrel node up and running so happy right now its good to be back!

Thank you @pierreschwang and thank you @5hack

PS does anyone know the terminal login?

Default is umbrel / umbrel

1 Like

I’ve just singed-up to say you are the GOAT
Thank you !

What URL are you opening? I’m trying http://127.0.0.1/, umbrel.local etc and getting site not available… my VM boots after the installation

Thank you! That worked for me :slight_smile: