Umbrel 0.4.2 is out with a new app, performance upgrades, and more

Umbrel 0.4.2 is out with the latest versions of Samourai Server, Home Assistant, BTCPay Server, Nextcloud, BTC RPC Explorer, Pi-hole, Synapse, Element, LNbits, Gitea, code-server, and a brand new app — Squeaknode, to the Umbrel App Store, along with an updated Electrum server, performance upgrades, bug fixes, and more. :tada:

Simply login to your Umbrel to update. :rocket:

Squeaknode, the new app in the Umbrel App Store, is built by Jonathan Zernik and it’s like a P2P Twitter (or OnlyFans?) built on the Lightning Network where you can pay to unlock tweets.

If you’ve faced connectivity issues between Samourai Wallet and Dojo/Whirlpool on your Umbrel, the latest version of Samourai Server should fix them.

And if you’ve faced connectivity issues between BlueWallet (onchain) and your Umbrel, the latest version of Electrum server should fix them.

The Element app has also been updated to the latest version released today which fixes a critical security vulnerability. So if you’re using Element, make sure to update quickly.

Also included is better error-handling with actionable feedback in scenarios such as if Umbrel fails to connect to your external drive, if there’s an issue booting up, or if any of the system services fails.

Twitter announcement:


I’ve been stuck on the “Removing old containers…” part of the update for over an hour. Is there a window of how long the update should take?



1 Like

I tried to install the new version, but it would do the “Backing up” progress and then back out to the dashboard in a few seconds. I tried rebooting and then updating again, but it did the same thing again, so I just wiped the microSD card, flashed 0.4.1. The dashboard prompted me to update to 0.4.2, which it went without any issues this time. I don’t know why it wouldn’t update before I had to wipe the microSD card. So this is a tip for anyone who ran into the same issue I had.

1 Like

What’s the verdict, safe to upgrade?

Post and let us know if you upgraded with or without issues.

Just updated without any issues. Whole process took approx 4 mins.
Two thumbs up.

Just updated with no issues

After Upgrade how long before the “Maintenance mode” for Nextcloud goes away?

Hi, I am trying to update to the latest version and has been stuck in the process. I try to reload from cmd line and it gives me the following error: Error: Umbrel can only be configured for mainnet (default), testnet or regtest

Were you completely sync’d and up and running, or in some level of sync mode?

Confirming I was already up and running and fully synced.