Transfer node from Pi to Ubuntu Linux Desktop, re-using the external SSD

Hi! Should be simple, but I can’t seem to figure it out. I have Umbrel node working on a Pi 4, been running for a couple of years, blockchain data stored on a 1TB external SSD. I’d like to move the node to a higher powered desktop running Ubuntu, but use the same SSD (just plugged into the new machine).

First I fresh installed Umbrel on Linux, then realized my internal NVME wasn’t going to be big enough. So I plugged the SSD from the Pi into my desktop. It mounted, and I ran the /umbrel/scripts/start from the SSD’s umbrel directory.

To my surprise, Umbrel fired right up! I could access the GUI from a browser and login with my old password, but then none of the apps seemed to load, all remained stuck at “loading”.

Since it’s so close, I feel like I can probably just tweak the mount or something and get the whole thing running, but can’t figure it out yet. Any ideas? Thanks!

Just a follow up for posterity. I got it working, but I’m not exactly sure what did the trick. Node is running, and all of my sats are there and apps are working as previously configured. I THINK it was that I tried actually mounting the external drive to the filesystem. Either that or I just didn’t wait long enough after. I think this would be worth investigating, as more people may be interested in quickly and easily upgrading their nodes to better hardware.

Steps are something like:

  1. Install Umbrel on the new machine to make sure all dependancies are in place, using the normal bash script:
    curl -L https://umbrel.sh | bash
    1.5. Stop that Umbrel instance.
    sudo ~/umbrel/scripts/stop

  2. Plug in the external hard drive and mount it to the filesystem.
    sudo fdisk -l
    sudo mkdir /mnt/usb
    sudo mount /dev/sdb1 /mnt/usb (change “sdb1” to whatever your drive is named in fdisk")

  3. Start the Umbrel instance from the external drive:
    sudo /mnt/usb/umbrel/scripts/start

I’m sure this is wrong, but something like that.

Currently UmbrelOS is at v1.1 or so. A lot of info in this post is not applicable anymore.

I managed to do this with v1.1. Please see my post at Migrate/Re-use UmbrelOS SSD from Raspberry Pi to X86 – Jun Sun's Journal

The key is to mount ssd on PC and create a symlink to /mnt/umbrel-ssd/umbrel under /home/umbrel/umbrel. Of course you need to use systemctl to stop/start umbrel service before and after this linking.