The Bitcoin Machine upgrading from v5.x

I had a TBM device running Umbrel 0.5.4 and first tried to click the “install update” to go to 1.x, but that didn’t work, of course. Lots of re-booting and re-trying and the result was that I was still on 0.5.4 but none of my apps were there. Not too worried about that as I can just reinstall them later.

I’ve followed lots of guides and tried to install via pulling the microSD and flashing. the lcd got wiped out, but I also cannot load https://umbrel.local anymore. nor can I ssh to that address.

I just tried with v1.1.2 found here (Releases · getumbrel/umbrel · GitHub) but got the same result.

At one point, i saw a guide say to go to umbrel.local or to use some utility to locate where it was on the network if it wasn’t there… I don’t remember what that was.

Earlier today I found umbrel-os-v0.5.4-patch-1.img which I flashed and the system came up as it was before.

So, I guess that’s my only hope at this point, unless any wizards here have any helpful device to get me up to the current release. Sure wish this darn TBM had an hdmi port or something to see what’s going on…

Thanks for any help anyone may have.