The Bitcoin Machine - Blank LCD Since Umbrel OS 1

I have recently updated my Umbrel node running on “The Bitcoin Machine” and the display no longer shows anything.

The installation package over at " doidotech/TBM: Repository contains LCD setup scripts for nodes (" does not work on the new build and gives errors

“error: externally-managed-environment”

It would appear that the installation scripts need updating, this is beyond my abilities and the “TBM Team” vanished without trace last year.

This product was pushed heavily by Umbrel as a partner, has anyone looked into this error or will umbrel be giving any support ?.

Worst case is is possible to revert back to an older version of Umbrel so that my TBM machine is not useless ?


1 Like

I am in the same boat as you. Umbrel 1.0 was a pretty big change so you are correct that the scripts will need to be updated to work properly. I’ve managed to get it working somewhat by doing the following.

Run the setup script as instructed. The first error you’ll get is an environment issue. You can bypass that by following the steps listed here . Then you’ll be left with an error about modifying the config.txt file.

Next you’ll have to remove the SD card from TBM (the bitcoin machine) and mount it in another device you can then modify the config.txt file on the BOOT-A volume. You need to add a line at the end of that file that says “dtparam=spi=on” no quotes. Save file, reinsert the SD card into TBM and boot up. You might need to run the LCD setup again, you’ll get the same errors but after a few seconds it should work.

Currently the only screens that function appear to be the DATE/TIME and Storage. Think the others will need to be modified for the changes made in the Umbrel 1.0 update. I might get around to tinkering with this later on but for now at least I have the screen working and not just a plain white display.


Any news with Umbrel 1.1? Still not working? Tried to setup only 1.0.

I’m thinking to take rasp + SSD + SD card with 1.1 out of this case and setup second Umbrel with old version just to make display running again. Quite expensive BTC price ticker I know. I want to separate BTC stuff from multimedia stuff anyway.

1 Like

i am not updating couse of the screen, unfortunatelly

1 Like

Found this forked repository:

3 months ago updated for Umbrel 1.0

Any volunteers to try if this works?

1 Like

Thats my repository, I took a fork as I didnt trust the owners to not just vanish. This is an exact copy so also does not work.


I would also like to see the LCD working in 1.x
+1 to the vote.

1 Like

Seconded, will keep an eye on this thread. Ironically i found it very simple to follow the LCD updates for TBM and thought it looked great, was able to change to my local currency etc and update the date/time location with ease. I then decided to update to 1.0, snapped my micro SD removing it… loaded the OS onto a new one and plugged it all in only to be greeted with a blank screen :frowning: Umbrel is working fine, just gutted that the TBM LCD hasnt had an update yet.

Happy to donate a few sats to whoever fancies working this one out please!