System doesn't boot (fail to mount) and GRUB menu non existent for troubleshooting

My system doesn’t boot (fails to mount) and won’t allow me to access the root user from emergency mode (“the root account is locked”). I found that I should be able unlock the root user by accessing the GRUB menu. But no hotkey works on boot.

I can mount Umbrel OS system as an external drive by booting from a live USB, and access its files that way. I can see Umbrel OS only has the “EFI/boot/grub.cfg” file and there’s no “etc/default/grub” file

I tried opening the GRUB menu but no hotkey works to bring it up. How is this possible?

I just need access to command line so I can troubleshoot with journalctl why the system won’t boot.

Dell laptop.
Umbrel OS installed on external storage device.

I solved the problem in 2 steps:

  1. I unlocked the root user:
    To unlock the root user I booted from a live USB, then mounted the HDD with Umbrel, and used the “chroot” method to root into the file system and change its root’s user password. Here are the commands I used:
sudo mount /dev/sdc2 /mnt/c2
sudo mount /dev/sdc1 /mnt/c1
sudo mount -t proc none /mnt/c2/proc
sudo mount --bind /sys /mnt/c2/sys
sudo mount --rbind /dev/ /mnt/c2/dev

sudo /usr/sbin/chroot /mnt/c2
sudo passwd root

Then reboot into the HDD and the emergency mode allowed me access to root.
Then I used the journalctl -xb command and saw that the HDD mount was timing out after 3 minutes (Umbrel OS is VERY IMPATIENT)

  1. To fix the mount error, I added the mount option “x-systemd.mount-timeout=600” in /etc/fstab for the /data partition
    So the line in my fstab file looks like this:
/dev/disk/by-partuuid/d1d36e34-2753-4dc7-96eb-3c9b5584e867   /data          auto       defaults,x-systemd.growfs,x-systemd.mount-timeout=600      0  0

In summary:
Umbrel should unlock root user by default so we can troubleshoot in cases like these, and it should also add more patience for the mount process, by default.