Stuck "Removing old Containers"

Updating to 0.4.6 and Umbrel has hung on “Removing old containers” for 8 hours. Went Telegram group for help. Someone posted (I assumed was replying to me):
scripts/update/update --repo getumbrel:umbrel#0.4.6
These didn’t work, so I found where the scripts directory was and modified the cmds to:
sudo ./scripts/stop
which appeared to work by stopping containers until this

Stopping Docker services…
Removing network umbrel_main_network
ERROR: error while removing network: network umbrel_main_network id c9e7304f15e068caaa9415d2732d1a9859059111308aa5d1a49d281648a49fdf has active endpoints

Next I ran this
sudo scripts/update/update --repo getumbrel:umbrel#0.4.6

Which gave me this:
Cloning into ‘/tmp/umbrel-update’…
remote: Not Found
fatal: repository ‘’ not found
fatal: not a git repository: ‘/tmp/umbrel-update//.git’
mv: cannot stat ‘/tmp/umbrel-update//info.json’: No such file or directory
jq: error: Could not open file /tmp/umbrel-update//info.json.orig: No such file or directory
Update path doesn’t seem to be an Umbrel install.

Now its broken :frowning:
Any tips on where to go from here… ??

(Raspberry PI 8Gb, Ethernet, Samsung T5 SSD)

Still looking into it, and tried this for a manual update
cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.4.6
and then a
sudo reboot

looks like it worked.
I’ll leave this here for reference