Stuck "Deleting previous images..." since 0.4.8 upgrade

On the day the 0.4.8 upgrade came out I stupidly upgraded my RasPi 4 without any thought, and ever since, for like a week now or so, I’ve had the “Deleting previous images…” screen stuck when going into my node. Reboots don’t affect it at all.

So I read through some threads here and tried two things, both to no avail:

  1. I made a new image of v0.4.8, flashed it to a brand-new high-speed 32mb MicroSDHC mem card, and booted my umbrel with that. No change. (Except that it reset my password to the node back to the default)

  2. I removed the file (through Putty) ./statuses/update-in-progress
    No change at all here either, even after a reboot.

What else can I try? I have a lot of sats in lots of channels on this node and absolutely cannot wipe the data in my bitwarden app. In fact I need access to that asap. Help!

1 Like

Whew, Finally figured it out with this manual, DarthCoin.
There was one thing wrong in there that you might want to update under the update section. You wrote:

" If the update was stuck in update, run this before the above command:
sudo rm statuses/update-in-progress"

The problem was that I wasn’t able to delete that file because it simply isn’t named that. I guess devs changed the name at some point. The file I deleted that fixed everything and brought my node roaring to life was:


Deleting that solved everything. I’m resolved now, thanks!

1 Like

Thanks, I updated the troubleshooting manual

1 Like