Issue with Specter Desktop

Hello there.

I am new to the world of Umbrel, and am having issues with the installations. I am hoping some of the community would be able to answer my questions to help me set up and run a node.

Background: I had a lot of issues with the Umbrel Home out of the box, but was able to overcome these via accessing the device via the IP not http://umbrel.local (on a Mac) and then reflashing the SSD to enable me to download apps (my original query here). I am not sure if this in pertinent to the issues I am now facing or not - but I thought I would include for context.

I am trying to now setup Spector to circumvent the need to set up SatStack to connect my ledger live.

I am running into the following issues:

Specter encountered an error:
Specter exited with exit code 1. Check the logs in the menu for more details.

Does anyone know what this means?

I have downloaded the Spector logs and will past them into a reply comment to his post.

Here is the Spector log (copied into a txt file).

Spector logs.txt (52.8 KB)


I have also tried to reinstall Specter Desktop without any luck.

Additional items I tried (with the help of the SpecterCommunity) are:

  • I deleted the files ~/Library/application support/Specter
  • I removed the < user >/.specter folder (using Cmd + Shift + . to reveal hidden files)
  • I disconnected the node from ledger setting/experimental features/connect bitcoin full node

Just waiting on some work to finish processing, then I will restart the Mac and try again this worked.

If anyone else has had a similar issue I would be really grateful to hear what you tried.